UVA11369 POJ3637 HDU1678 Shopaholic【貪心】

Shopaholic
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5477 Accepted: 3161

Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1 ≤ t ≤ 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 ≤ n ≤ 20000. The next line gives the prices of these items, 1 ≤ pi ≤ 20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1
6
400 100 200 350 300 250

Sample Output

400

Source

Nordic 2007

問題鏈接UVA11369 POJ3637 HDU1678 Shopaholic
問題簡述:商店打折,每買三件商品中最便宜的不要錢,問最多省多少錢。
問題分析
    貪心,最貴和次貴的商品是不可能省錢的,第3貴的商品是可能省錢的最大值,這時需要買下最貴的3件商品。重複這樣的過程即可。
    排序是必要的。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* UVA11369 POJ3637 HDU1678 Shopaholic */

#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;

const int N = 20000;
int p[N];

int main()
{
    int t, n;
    scanf("%d", &t);
    while(t--) {
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%d", &p[i]);

        sort(p, p + n);

        int sum = 0;
        for(int i = n - 3; i >= 0; i -= 3)
            sum += p[i];

        printf("%d\n", sum);
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章