UVA812 WF5212 POJ1874 Trade on Verweggistan【暴力+DFS】

Trade on Verweggistan
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 1935 Accepted: 554

Description

Since the days of Peter Stuyvesant and Abel Tasman, Dutch merchants have been traveling all over the world to buy and sell goods. Once there was some trade on Verweggistan, but it ended after a short time. After reading this story you will understand why.

At that time Verweggistan was quite popular, because it was the only place in the world where people knew how to make a ‘prul’. The end of the trade on Verweggistan meant the end of the trade in pruls (or ‘prullen’, as the Dutch plural said), and very few people nowadays know what a prul actually is.

Pruls were manufactured in workyards. Whenever a prul was finished it was packed in a box, which was then placed on top of the pile of previously produced pruls. On the side of each box the price was written. The price depended on the time it took to manufacture the prul. If all went well, a prul would cost one or two florins, but on a bad day the price could easily rise to 15 florins or more. This had nothing to do with quality; all pruls had the same value.

In those days pruls sold for 10 florins each in Holland. Transportation costs were negligible since the pruls were taken as extra on ships that would sail anyway. When a Dutch merchant went to Verweggistan, he had a clear purpose: buy pruls, sell them in Holland, and maximize his profits. Unfortunately, the Verweggistan way of trading pruls made this more complicated than one would think.

One would expect that merchants would simply buy the cheapest pruls, and the pruls that cost more than 10 florins would remain unsold. Unfortunately, all workyards on Verweggistan sold their pruls in a particular order. The box on top of the pile was sold first, then the second one from the top, and so on. So even if the fifth box from the top was the cheapest one, a merchant would have to buy the other four boxes above to obtain it.

As you can imagine, this made it quite difficult for the merchants to maximize their profits by buying the right set of pruls. Not having computers to help with optimization, they quickly lost interest in trading pruls at all.

In this problem, you are given the description of several workyard piles. You have to calculate the maximum profit a merchant can obtain by buying pruls from the piles according to the restrictions given above. In addition, you have to determine the number of pruls he has to buy to achieve this profit.

Input

The input describes several test cases. The first line of input for each test case contains a single integer w, the number of workyards in the test case (1 <= w <= 50).
This is followed by w lines, each describing a pile of pruls. The first number in each line is the number b of boxes in the pile (0 <= b <= 20). Following it are b positive integers, indicating the prices (in florins) of the pruls in the stack, given from top to bottom.

The input is terminated by a description starting with w = 0. This description should not be processed.

Output

For each test case, print the case number (1, 2, …). Then print two lines, the first containing the maximum profit the merchant can achieve. The second line should specify the number of pruls the merchant has to buy to obtain this profit. If this number is not uniquely determined, print the possible values in increasing order. If there are more than ten possible values, print only the 10 smallest.
Display a blank line between test cases.

Sample Input

1
6 12 3 10 7 16 5
2
5 7 3 11 9 10
9 1 2 3 4 10 16 10 4 16
0

Sample Output

Workyards 1
Maximum profit is 8.
Number of pruls to buy: 4

Workyards 2
Maximum profit is 40.
Number of pruls to buy: 6 7 8 9 10 12 13

Source
World Finals 1999

問題鏈接UVA812 WF5212 POJ1874 Trade on Verweggistan
問題簡述:給定b個序列(b行),每個序列給出k,表示有k個元素,每行只能從頭取,取i(i≤k),現在要在每個序列前取走c[i]個,保證說sum = ∑10 - p (p爲所選數的集合)最大,計算輸出可以選擇的個數,超過10個的話只輸出最小的10個。
問題分析:暴力搜索,給代碼,暫時不解釋。
程序說明:程序在WF5212(UVALive5212)中出現WA。
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* UVA812 WF5212 POJ1874 Trade on Verweggistan */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

const int TEN = 10;
const int W = 50;
vector<int> v[W];
const int N = 1000;
int w, ans, cnt[N];

void init()
{
    ans = 0;
    int b, p;
    for (int i = 0; i < w; i++) {
        v[i].clear();
        v[i].push_back(0);
        scanf("%d", &b);
        int sum = 0, maxp = 0;
        for(int j = 1; j <= b; j++) {
            scanf("%d", &p);
            sum += TEN - p;
            if(sum > maxp) {
                maxp = sum;
                v[i].clear();
                v[i].push_back(j);
            } else if(sum == maxp)
                v[i].push_back(j);
        }
        ans += maxp;
    }
}

void dfs(int d, int s)
{
    if(d >= w) { cnt[s] = 1; return;}
    for(int i = 0; i < (int)v[d].size(); i++)
        dfs(d + 1, s + v[d][i]);
}

void solve()
{
    memset(cnt, 0, sizeof(cnt));
    dfs(0, 0);

    int cnt2 = 0;
    for(int i = 0; i < N; i++)
        if(cnt[i]) {
            printf(" %d", i);
            if(++cnt2 == TEN) break;
        }
    printf("\n");
}

int main()
{
    int caseno = 0;
    while(~scanf("%d", &w) && w) {
        init();
        if(caseno++) printf("\n");
        printf("Workyards %d\n", caseno);
        printf("Maximum profit is %d.\n", ans);
        printf("Number of pruls to buy:");
        solve();
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章