A+B for Input-Output Practice Java語言實驗 SDUT OJ1017

A+B for Input-Output Practice

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

Your task is to calculate the sum of some integers

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6
import java.util.Scanner;
public class Main 
{
	public static void main(String[] args)
	{
		Scanner reader = new Scanner(System.in);
		int x, n, m;
		m = reader.nextInt();
		while(m-- > 0)
		{
			x = 0;
			n = reader.nextInt();
			while(n-- > 0)
			{
				x += reader.nextInt();
			}
			System.out.println(x);
			System.out.println();
		}
		reader.close();
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章