习题5.13 词频统计 (30分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:

(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is
#include <iostream>
#include <map>
#include <set>
#include <string>
using namespace std;

struct Node {
	string str;
	int count;
	bool operator<(const Node& s)const {
		return count == s.count ? str<s.str : count>s.count;
	}
};

int main() {
	set<Node>st;
	map<string, int>mp;
	string s;
	char c;
	while (scanf("%c", &c) && c != '#') {
		if (isalnum(c) || c == '_') {
			if (isalpha(c))
				c = tolower(c);
			s += c;
		}
		else if (s.size()) {
			if (s.size() > 15)
				s = s.substr(0, 15);
			mp[s]++;
			s.clear();
		}
	}
	for (auto& it : mp)
		st.insert({ it.first,it.second });
	int cnt = st.size();
	cout << cnt << endl;
	cnt /= 10;
	for (auto& it : st) {
		cout << it.count << ":" << it.str << endl;
		if (!--cnt)
			break;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章