JAVA判斷合法標識符 Java語言實驗 SDUT OJ3328

JAVA判斷合法標識符

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

輸入若干行字符串,判斷每行字符串是否可以作爲JAVA語法的合法標識符。 判斷合法標識符的規則:由字母、數字、下劃線“_”、美元符號“$”組成,並且首字母不能是數字。

Input

 輸入有多行,每行一個字符串,字符串長度不超過10個字符,以EOF作爲結束。

Output

 若該行字符串可以作爲JAVA標識符,則輸出“true”;否則,輸出“false”。

Sample Input

abc
_test
$test
a 1
a+b+c
a’b
123
變量

Sample Output

true
true
true
false
false
false
false
true

Hint

Source

houxq

import java.util.Scanner;
public class Main 
{
	public static void main(String[] args)
	{
		Scanner reader = new Scanner(System.in);
		String str;
		char start, ch;
		int len, flag, i;
		while(reader.hasNext())
		{
			str = reader.nextLine();
			len = str.length();
			start = str.charAt(0);
			flag = 1;
			if(!Character.isJavaIdentifierStart(start))
			{
				flag = 0;
			}
			else
			{
				for(i = 1; i < len; i++)
				{
					ch = str.charAt(i);
					if(!Character.isJavaIdentifierPart(ch))
					{
						flag = 0;
						break;
					}
				}
			}
			if(flag == 1)
			{
				System.out.println("true");
			}
			else
			{
				System.out.println("false");
			}
		}
		reader.close();
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章