構建完全二叉搜索樹

7-7 Complete Binary Search Tree (30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define max 1000

int A[max];
int result[max] = {0};

int min(int a,int b){
    return a<b?a:b;
}

int getLeftLength(int A_length){
    int h;  //完全二叉樹層數
    h = (int)(log(A_length+1)/log(2));
    int x = A_length-pow(2,h)+1;  //底下一層元素個數
    x = min(x,pow(2,h-1));
    return pow(2,h-1)-1+x;
}

int compare(const void* a,const void* b){
    return *(int*)a-*(int*)b;
}

void solve(int left,int length,int root){
    if(length==0)   return;
    int L = getLeftLength(length);
    int R = length-L-1;
    result[root] = A[left+L];
    solve(left,L,2*root+1);
    solve(left+L+1,R,2*root+2);
}

int main(){
	freopen("1.txt","r",stdin);
    int N;
    scanf("%d\n",&N);
    for(int i=0;i<N;i++){
        scanf("%d",&A[i]);
    }
    qsort(A,N,sizeof(int),compare);
    solve(0,N,0);
    printf("%d",result[0]);
    for(int i=1;i<N;i++){
        printf(" %d",result[i]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章