UVA10192 Vacation【LCS+DP+記憶化遞歸】

You are planning to take some rest and to go out on vacation, but you really don’t know which cities you should visit. So, you ask your parents for help. Your mother says “My son, you MUST visit Paris, Madrid, Lisboa and London. But it’s only fun in this order.” Then your father says: “Son, if you’re planning to travel, go first to Paris, then to Lisboa, then to London and then, at last, go to Madrid. I know what I’m talking about.”
    Now you’re a bit confused, as you didn’t expected this situation. You’re afraid that you’ll hurt your mother if you follow your father’s suggestion. But you’re also afraid to hurt your father if you follow you mother’s suggestion. But it can get worse, because you can hurt both of them if you simply ignore their suggestions!
    Thus, you decide that you’ll try to follow their suggestions in the better way that you can. So, you realize that the “Paris-Lisboa-London” order is the one which better satisfies both your mother and your father. Afterwards you can say that you could not visit Madrid, even though you would’ve liked it very much.
    If your father have suggested the “London-Paris-Lisboa-Madrid” order, then you would have two orders, “Paris-Lisboa” and “Paris-Madrid”, that would better satisfy both of your parent’s suggestions. In this case, you could only visit 2 cities.
    You want to avoid problems like this one in the future. And what if their travel suggestions were bigger? Probably you would not find the better way very easy. So, you decided to write a program to help you in this task. You’ll represent each city by one character, using uppercase letters, lowercase letters, digits and the space. Thus, you can have at most 63 different cities to visit. But it’s possible that you’ll visit some city more than once.
    If you represent Paris with ‘a’, Madrid with ‘b’, Lisboa with ‘c’ and London with ‘d’, then your mother’s suggestion would be ‘abcd’ and you father’s suggestion would be ‘acdb’ (or ‘dacb’, in the second example).
    The program will read two travel sequences and it must answer how many cities you can travel to such that you’ll satisfy both of your parents and it’s maximum.
Input
The input will consist on an arbitrary number of city sequence pairs. The end of input occurs when the first sequence starts with an ‘#’ character (without the quotes). Your program should not process this case. Each travel sequence will be on a line alone and will be formed by legal characters (as defined above). All travel sequences will appear in a single line and will have at most 100 cities.
Output
For each sequence pair, you must print the following message in a line alone:
Case #d: you can visit at most K cities.
    Where d stands for the test case number (starting from 1) and K is the maximum number of cities you can visit such that you’ll satisfy both you father’s suggestion and you mother’s suggestion.
Sample Input
abcd
acdb
abcd
dacb

Sample Output
Case #1: you can visit at most 3 cities.
Case #2: you can visit at most 2 cities.

問題鏈接UVA10192 Vacation
問題簡述:計算兩個字符串的最長公共子串。
問題分析
    用記憶化遞歸來實現。
    需要注意,由於字符串存儲於數組中,下標從0開始,所以寫出來的代碼需要略有不同。
程序說明:(略)
參考鏈接UVA111 History Grading【LCS+DP+記憶化遞歸】

題記:(略)

AC的C++語言程序如下:

/* UVA10192 Vacation */

#include <bits/stdc++.h>

using namespace std;

const int N = 100 + 1;
char a[N], b[N];
int dp[N][N];

int lcs(int r, int c)
{
    if(r < 0 || c < 0) return 0;
    else if(dp[r][c] != -1) return dp[r][c];
    else if(a[r] == b[c]) return dp[r][c] = lcs(r - 1, c - 1) + 1;
    else return dp[r][c] = max(lcs(r, c - 1), lcs(r - 1, c));
}

int main()
{
    int caseno = 0;
    while(gets(a) && a[0] != '#') {
        gets(b);

        memset(dp, -1, sizeof(dp));

        printf ("Case #%d: you can visit at most %d cities.\n", ++caseno, lcs(strlen(a) - 1, strlen(b) - 1));
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章