hdu 5437 優先隊列 模擬

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 6635    Accepted Submission(s): 1584


Problem Description
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some valuev, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a queryn Please tell Alisha who the nth person to enter her castle is.
 

Input
The first line of the input gives the number of test cases,T , where 1T15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1k150,000. The door would open m times before all Alisha’s friends arrive where 0mk. Alisha will have q queries where 1q100.

The ith of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi,1vi108, separated by a blank. Bi is the name of the ith person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1tk) and p(0pk) separated by a blank. The door will open right after the tth person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1th,...,nqth friends to enter her castle.

Note: there will be at most two test cases containing n>10000.
 

Output
For each test case, output the corresponding name of Alisha’s query, separated by a space.
 

Sample Input
1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3
 

Sample Output
Sorey Lailah Rose
 

Source

題意:

給出 k 個人按照順序來到主人公家門口,但是主人公太皮了,來了也不讓進

硬要等到第 i 個人到了才放 x  個人進門,進門還有條件,禮物貴重的先進,一樣貴重的禮物自然先到先進

然後有q個詢問,問你第 j 個進門的人是誰


注意:

文中這句話  The door will open right after the tth   person arrives  不一定說明 m 個放人進門是按照順序的

以及這句話  after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

表示最後大家都能進門


題解:

使用優先隊列模擬就好了


#include<queue>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 150005

struct node{
    char str[205];
    int w,t;
    bool operator < (const node& x) const {
        if(w==x.w) return t>x.t;
        return w<x.w;
    }
}a[maxn],ans[maxn];

struct time{
    int t,people;
    bool operator < (const time& x) const {
        return t<x.t;
    }
}door[maxn];
int query[maxn];

int main()
{
    int k,m,q,T;
    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&k,&m,&q);
        for(int i=0;i<k;i++)
            scanf("%s%d",a[i].str,&a[i].w),a[i].t=i+1;
        for(int i=0;i<m;i++)
            scanf("%d%d",&door[i].t,&door[i].people);
        sort(door,door+m);
        for(int i=0;i<q;i++)
            scanf("%d",&query[i]);

        int now=0,pos=0;
        door[m].t=0x3f3f3f;
        priority_queue<node>pp;
        for(int i=0;i<k;i++){
            if(a[i].t<=door[now].t)
                pp.push(a[i]);
            else{
                while((door[now].people--)&&(!pp.empty()))
                    ans[pos++]=pp.top(),pp.pop();
                pp.push(a[i]);
                now++;
            }
        }
        while(!pp.empty()) ans[pos++]=pp.top(),pp.pop();

        for(int i=0;i<q;i++)
            printf("%s%c",ans[query[i]-1].str,i!=q-1?' ':'\n');
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章