貪心-HDU1789 Doing Homework again(活動安排問題)

題目

傳送門: HDU-1789

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

input:

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

output:

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input:

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output:

0
3
5

題意

給出N個作業的截止日期和未完成的罰分,每天只能完成一個作業,求最小的罰分。

分析

首先把作業按截止日期從小到大排序,如果日期相同按罰分降序,我們希望完成儘可能多的作業。然而僅靠日期排序並不是最優的,當一項作業超過截止日期時,我們不能就簡單的加上罰分,我們要把它的罰分和前面完成作業的最小罰分相比(優先隊列實現),選擇罰分較小的那個。

代碼

#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 1003;
int t, n;
pair<int, int>p[maxn];
bool cmp(pair<int, int>a, pair<int, int>b) {
	if (a.first == b.first)
		return a.second > b.second;
	else return a.first < b.first;
}
struct cmp2 {
	bool operator()(pair<int, int>a, pair<int, int>b) {
		return a.second > b.second;

	}
};
int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].first);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].second);
		sort(p, p + n, cmp);//按日期升序罰分降序
		int ans = 0, day = 1;
		priority_queue<pair<int, int>,vector<pair<int, int>>, cmp2>q;
		for (int i = 0; i < n; i++)
			if (p[i].first < day) {//逾期
				if (q.top().second < p[i].second) {//和之前罰分最小的比較
					ans += q.top().second;
					q.pop();
					q.push(p[i]);
				}
				else ans += p[i].second;
			}
			else {
				q.push(p[i]);//入隊
				day++;
			}
		printf("%d\n", ans);
	}
	return 0;
}

你的點贊將會是我最大的動力

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章