HDU-1002,A + B Problem II(Java大數)

Problem Description:

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input: 

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output: 

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input: 

2

1 2

112233445566778899 998877665544332211 

Sample Output: 

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110 

AC Code: 

import java.util.*;
import java.math.*;
public class Main
{
	public static void main(String[] args)
	{
		Scanner input=new Scanner(System.in);
		int t=input.nextInt();
		int ans=1;
		for(int i=1;i<=t;i++)
		{
			BigDecimal a=input.nextBigDecimal();
			BigDecimal b=input.nextBigDecimal();
			System.out.println("Case "+ans+":");
			System.out.println(a+" + "+b+" = "+a.add(b));
			ans++;
			if(ans<=t)
				System.out.println();
		}
		input.close();
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章