Subsequence ZOJ:3123

Subsequence


Time Limit: 1 Second      Memory Limit: 32768 KB


A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.If no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
#include<bits/stdc++.h>
using namespace std;
int main() {
	int m;
	cin >> m;
	while (m--) {
		int n, s, sum(0), min(0);
		queue<int>q;
		cin >> n >> s;
		for (size_t i = 0; i < n; i++)
		{
			int temp;
			cin >> temp;
			sum += temp;
			q.push(temp);
			while (sum - q.front() > s)
			{
				sum -= q.front();
				q.pop();
			}
			if (sum >= s && (min > q.size() || min == 0)) {
				min = q.size();
			}
		}
		cout << min << endl;
	}
	//system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章