PTA_PAT甲級_1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:
Each input file contains one test case. Each case gives a positive integer N (≤104^) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

題意:
給出若干數,輸出他們能組合成的最小數

分析:
直接字符串排序然後合併再去除前導0,但排序規則不是直接比較大小,而是若S1+S2<S2+S1則S1排在S2前

代碼:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;

#define MAXN 10010
string str[MAXN];
bool cmp(string a, string b){
	return a+b<b+a;
}

int main()
{
    int N;
	cin>>N;
	for(int i=0;i<N;i++) cin>>str[i];
	sort(str, str+N, cmp);
	string ans;
	for(int i=0;i<N;i++) ans += str[i];
	while(ans.size()!=0 && ans[0]=='0')//去除前導0 
		ans.erase(ans.begin());
	if(ans.size()==0) cout<<0;
	else cout<<ans; 
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章