(uva 11300)分金幣(Spreading the Wealth)

11300 - Spreading the Wealth

Time limit: 6.000 seconds

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4


代碼:

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 1000000 + 10;
long long A[maxn], C[maxn], tot, M;
int main()
{
	int n;
	while(scanf("%d", &n) == 1)//輸入數據大,scanf比cin快
	{
		tot = 0;
		for(int i = 1; i <= n; i++)
		{
			scanf("%lld", &A[i]);//用%lld輸入long long
			tot += A[i];
		}
		M = tot / n;
		C[0] = 0;
		for(int i = 1; i < n; i++)
			C[i] = C[i-1] + A[i] - M;//遞推C數組
		sort(C, C+n);
		long long x1 = C[n/2], ans = 0;//計算x1
		for(int i = 0; i < n; i++)
			ans += abs(x1 - C[i]);//把x1代入,計算轉手的總金幣數
		printf("%lld\n", ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章