HDU1011——Starship Troopers(樹狀dp)



Starship Troopers

猿題庫

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17199    Accepted Submission(s): 4551


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 


Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 


Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 


Sample Input
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 


Sample Output
50 7
題意:
有一個軍隊n個人要佔領m個城市,每個城市有cap的駐紮兵力和val的珠寶,而且這m個城市的佔領先後具有依賴關係,軍隊的每個人可以打敗20個城市的防守者,而且佔領城市後可以得到城市的珠寶,問最多可以得到多少珠寶?
解題思路:
 dp[當前城堡][所用兵力] = 最大珠寶;
 主要思想,(可以分兵)怎樣去分兵,用j記錄攻下當前城堡的最少士兵k,然後依次增加直到所有兵都放在這裏,然後分兵給子樹,從1分到M-k;分別計算每點獲得珠寶,再與上層節點相加,結果與原來的初始化的結果相比取較大值。( dp[father][j] = max(dp[father][j], dp[father][j-z]+dp[child][z]) ).
代碼實現:
#include <iostream>
#include <stdio.h>
#include <cstdio>
#include <cstring>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <cmath>
#include <algorithm>

using namespace std;
const long long  maxn = 100000000+10;
typedef long long LL;
int castle[110], brain[110];
int vis[110], dp[110][110];
vector <int> vec[110];
int n, m;

void Fight( int S )
{
    vis[S] = 1;
    if( m < (castle[S]+19)/20 )
        return;
    int i, j;
    int k = (castle[S]+19)/20;
    for( i=k; i<=m; i++ )
    {
        dp[S][i] = brain[S];
    }
    for( i=0; i<vec[S].size(); i++ )
    {
        int t = vec[S][i];
        if(vis[t] == 1)
           continue;
        if( vec[t].size() > 0 ){
        Fight(t);
        for( j=m; j>k; j-- )                 // 這裏我也不清楚爲什麼要倒着,正着是A不了的.
            for( int z=0; z<=j-k; z++ )
                dp[S][j] = max(dp[S][j], dp[S][j-z]+dp[t][z]);
        }
    }
    if( dp[S][0] > 0 ){
        dp[S][1] = max(dp[S][0],dp[S][1]) ;
        dp[S][0] = 0;
    }
}

int main()
{
    while( scanf("%d%d",&n,&m)!=EOF )
    {
        if( n== -1 && m == -1 )
            break;
        memset(vis, 0, sizeof(vis));
        memset(castle, 0, sizeof(castle));
        memset(brain, 0, sizeof(brain));
        memset(dp, 0, sizeof(dp));
        int i, j, a, b;
        for( i=1; i<=n; i++ )
            vec[i].clear();
        for( i=1; i<=n; i++ )
        {
            scanf("%d%d", &castle[i],&brain[i]);
        }
        for( i=1; i<n; i++ )
        {
            scanf("%d%d",&a,&b);
            vec[a].push_back(b);
            vec[b].push_back(a);                    // 這裏我也不懂...
        }
        Fight(1);
        cout<< dp[1][m] <<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章