18年冬季第三題 PAT甲級 1154 Vertex Coloring (25分) 兩種思路

題目來源:https://pintia.cn/problem-sets/994805342720868352/problems/1071785301894295552

備考彙總貼:2020年3月PAT甲級滿分必備刷題技巧

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

題目大意(本欄、思路一及其代碼源自liuchuo,我改得更通順和好懂)

給出一個圖(即給出所有邊),然後給出多種圖着色的查詢,問是否滿足 k個顏色的圖着色(i.e. 塗上k個顏色後,所有的邊的兩個點的顏色不相同),如果滿足還要指明k是多少。

題目分析

思路一:把所有邊存起來,把所有點的顏色存起來(存的過程中放入set統計顏色個數),枚舉所有邊,檢查是否每條邊的兩點個顏色是否相同;若全不相同,則輸出顏色個數k,否則輸出No

思路二:用鄰接表的方式存圖(雙重vector),訪問每個頂點的鄰接頂點,如果存在顏色相同就輸出No;如果全部都不同,就輸出顏色個數k,否則輸出No

滿分代碼

思路一

#include <iostream>
#include <vector>
#include <set>
using namespace std;
struct node {int t1, t2;};
int main() {
    int n, m, k;
    cin >> n >> m;
    vector<node> v(m);
    for (int i = 0; i < m; i++)
        scanf("%d %d", &v[i].t1, &v[i].t2);
    cin >> k;
    while (k--) {
        int a[10009] = {0};
        bool flag = true;
        set<int> se;
        for (int i = 0; i < n; i++) {
            scanf("%d", &a[i]);
            se.insert(a[i]);
        }
        for (int i = 0; i < m; i++) {
            if (a[v[i].t1] == a[v[i].t2]) {
                flag = false;
                break;
            }
        }
        if (flag) 
            printf("%d-coloring\n", se.size());
        else 
            printf("No\n");
    }
    return 0;
}

思路二

#include<iostream>
#include<vector>
#include<set>
using namespace std;
int main(){
    int n,m,k,a,b;
    scanf("%d %d",&n,&m);
    vector<vector<int>> v(n);
    for(int i=0;i<m;i++){
        scanf("%d %d",&a,&b);
        v[a].push_back(b);
        v[b].push_back(a);
    }
    scanf("%d",&k);
    for(int i=0;i<k;i++){
        vector<int> t(n);
        set<int> kc;
        for(int j=0;j<n;j++){
            scanf("%d",&t[j]);
            kc.insert(t[j]);
        }
        bool flag=true;
        for(int j=0;j<n;j++){
            for(auto it:v[j]){
                if(t[it]==t[j]){
                    flag=false;
                    break;
                }
            }
        }
        if(flag)printf("%d-coloring\n",kc.size());
        else printf("No\n");
    }
    return 0;
}

 

備考彙總貼:2020年3月PAT甲級滿分必備刷題技巧

如果喜歡我的博客,請爲我點個贊,也歡迎多評論、轉發,感謝!!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章