19春第三題 PAT甲級 1158 Telefraud Detection (25分) 用這個方法最好

題目

Telefraud(電信詐騙) remains a common and persistent problem in our society. In some cases, unsuspecting victims lose their entire life savings. To stop this crime, you are supposed to write a program to detect those suspects from a huge amount of phone call records.

A person must be detected as a suspect if he/she makes more than K short phone calls to different people everyday, but no more than 20% of these people would call back. And more, if two suspects are calling each other, we say they might belong to the same gang. A makes a short phone call to B means that the total duration of the calls from A to B is no more than 5 minutes.

Input Specification:
Each input file contains one test case. For each case, the first line gives 3 positive integers K (≤500, the threshold(閾值) of the amount of short phone calls), N (≤10​^3​​, the number of different phone numbers), and M (≤10^​5​​, the number of phone call records). Then M lines of one day's records are given, each in the format:

caller receiver duration

where caller and receiver are numbered from 1 to N, and duration is no more than 1440 minutes in a day.

Output Specification:
Print in each line all the detected suspects in a gang, in ascending order of their numbers. The gangs are printed in ascending order of their first members. The numbers in a line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

If no one is detected, output None instead.

Sample Input 1:

5 15 31
1 4 2
1 5 2
1 5 4
1 7 5
1 8 3
1 9 1
1 6 5
1 15 2
1 15 5
3 2 2
3 5 15
3 13 1
3 12 1
3 14 1
3 10 2
3 11 5
5 2 1
5 3 10
5 1 1
5 7 2
5 6 1
5 13 4
5 15 1
11 10 5
12 14 1
6 1 1
6 9 2
6 10 5
6 11 2
6 12 1
6 13 1


Sample Output 1:

3 5
6


Note: In sample 1, although 1 had 9 records, but there were 7 distinct receivers, among which 5 and 15 both had conversations lasted more than 5 minutes in total. Hence 1had made 5 short phone calls and didn't exceed the threshold 5, and therefore is not a suspect.

Sample Input 2:

5 7 8
1 2 1
1 3 1
1 4 1
1 5 1
1 6 1
1 7 1
2 1 1
3 1 1


Sample Output 2:
 

None

題庫類似題

1034,這道題能用兩種方法做:
(1)並查集(https://blog.csdn.net/a617976080/article/details/99436602
(2)DFS(https://blog.csdn.net/liuchuo/article/details/52291920

如果目的就是準備考試,那建議兩種都讓自己獨立寫一寫,不要偷懶。

題目大意

給定以下條件,作爲電信詐騙團伙的判斷:
1. 一個人給不同的K個以上的人打電話,其中給每個人的通話總和不超過5分鐘的,稱爲短通話,短通話中只有不超過20%的人給他回電;
2.滿足1的兩個人互相通話,就是同一個團伙。

要根據通話記錄,分析出團伙的成員,按照從小到大的序號輸出成員編號。

難點

1.要想到這道題適合用並查集,就得熟悉並查集的特點:A和B關聯,B和C關聯,則認爲A和C關聯。這道題是符合的。
如果不引入這種非線性的數據結構,而採用向量、集合的話,寫判斷是會很麻煩的。

2.並查集在近三年的考題裏就出現過這一次,最有效率的方式是能熟練運用兩個並查集算法的函數:
 

int Findfather(int v){//這個遞歸寫法最簡單,而且包含路徑壓縮
    return v==father[v] ? v : father[v] = Findfather(v);
}
void Union(int a,int b){
    int faA=Findfather(a);
    int faB=Findfather(b);
    if(faA < faB){//這個得按照題目的意思變
        father[faA]=faB;
    }else if(faA > faB){
        father[faB]=faA;
    }
}

滿分代碼

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1005;
int n,m,k;
int father[maxn],G[maxn][maxn],visit[maxn];
vector<int> gang;
int findfather(int v){
    return v==father[v] ? v : father[v] = findfather(v);
}
void u(int a,int b){
    int faA=findfather(a);
    int faB=findfather(b);
    if(faA < faB){
        father[faA]=faB;
    }else if(faA > faB){
        father[faB]=faA;
    }
}
int main(){
    scanf("%d %d %d",&k,&n,&m);
    fill(G[0],G[0]+maxn*maxn,0);
    fill(visit,visit+maxn,0);
    for(int i=1;i<=n;i++){
        father[i]=i;
    }
    int a,b,c;
    for(int i=0;i<m;i++){
        scanf("%d %d %d",&a,&b,&c);
        G[a][b]+=c;
    }
    for(int i=1;i<=n;i++){
        int sc=0,bc=0;
        for(int j=1;j<=n;j++){
            if(i==j)continue;
            if(G[i][j]>0 && G[i][j]<=5){
                sc++;
                if(G[j][i]>0){
                    bc++;
                }
            }
        }
        if(sc>k && bc*5<=sc){
            gang.push_back(i);
        }
    }
    for(int i=0;i<gang.size();i++){
        for(int j=0;j<gang.size();j++){
            if(i==j)continue;
            int x=gang[i],y=gang[j];
            if(G[x][y]!=0 && G[y][x]!=0){
                u(x,y);
            }
        }
    }
    for(int i=0;i<gang.size();i++){
        int x=gang[i];
        if(visit[x]==1)continue;
        visit[x]=1;
        printf("%d",x);
        for(int j=i+1;j<gang.size();j++){
            int y=gang[j];
            if(visit[y]==0 && findfather(x)==findfather(y)){
                visit[y]=1;
                printf(" %d",y);
            }
        }
        printf("\n");
    }
    if(gang.size()==0)printf("None\n");
    return 0;
}

感謝觀看!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章