Hdu-3746-Cyclic Nacklace-【KMP】

傳送門:http://acm.hdu.edu.cn/showproblem.php?pid=3746


Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9963    Accepted Submission(s): 4257


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
3 aaa abca abcde
 

Sample Output
0 2 5
 

Author
possessor WC
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1358 1686 2222 3068 2896 
 

題意:給出一個字符串,問在首尾添加多少個字符可以形成至少2個循環   如 abca  需要添加 bc 纔可以

解題:用KMP裏面的next數組,找個字符串多實驗幾遍就可以得出怎樣輸出了

     

#include<cstdio>
#include<cstring>
char s[100010];
int next[100010],len;
void Next()
{
	int i=0,j=-1;
	next[0]=-1;
	while(i<len)
	{
		if(s[i]==s[j]||j==-1)
			next[++i]=++j;
		else
			j=next[j];
	}
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%s",s);
		len=strlen(s);
		Next();
		int l=len-next[len];		//循環節長度 
		if(len%(len-next[len])==0&&len!=len-next[len])
			printf("0\n");
		else
			printf("%d\n",l-len%(len-next[len])); //找個字符串試驗試驗就可以了 
	}
	return 0;
}
//  實驗 ababa   abcab


/*void Kmp()
{
	int i=0,j=0;
	while(i<len)
	{
		if(s[i]==next[j]||j==-1)
		{
			i++;j++;
		}
		else
		j=next[j];
		if(j==len2)
		{
			sum++;
			j=0;
		}
	}
}*/


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章