uva 11889 Benefit(簡單數學)


                                                 Benefit

Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to Cand he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.

You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students' benefit which is the lowest of them.

Input 

The first line begin with an integer T ( T$ \le$100000), the number of tests. Each test that comes in a separate line contains two integers A and C ( 1$ \le$AC$ \le$107).

Output 

Print the lowest integer B such that LCM(AB) = C in a single line. If no such integer exists, print "NO SOLUTION" instead. (Quotes for clarity)

Sample Input 

3
2 6
32 1760
7 16

Sample Output 

3
55
NO SOLUTION

題意:給你a,c,然你求最小的b使得LCM(a,b)=c;,沒有答案則輸出“NO SOLUTION”;

c%a必須等於0,不等於0,輸出NO SOLUTION ,c=g*a1*b1;求出b1=c/a;然後求出g,最後答案就是g*b1;

代碼:
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<vector>
#include<stdlib.h>
#include<string>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<set>
#define inf 0x3f3f3f3f
#define eps 1e-5
#define max(a,b) (a)>(b)?(a):(b)
#define min(a,b) (a)<(b)?(a):(b)
using namespace std;
int gcd(int a,int b)
{
    if(!b)return a;
    return gcd(b,a%b);
}
int main()
{
    int t,a,c;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%d",&a,&c);
            if(c%a!=0)
            {
                printf("NO SOLUTION\n");
            }
            else
            {
                 int b=c/a;
                 int ans=1;
                 int gg=gcd(a>b?a:b,a>b?b:a);
                 while(gg>1)
                 {
                     a/=gg;
                     ans*=gg;
                     gg=gcd(a>b?a:b,a>b?b:a);
                 }
                 printf("%d\n",ans*b);
            }
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章