杭電 Largest prime factor

Problem Description
Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.
 
Input
Each line will contain one integer n(0 < n < 1000000).
 
Output
Output the LPF(n).
 
Sample Input
1
2
3
4
5
 
Sample Output
0
1
2
1
3
#include<iostream>
#include<stdio.h>
#include<cstring>
using namespace std;
int a[1000001],b[1000001];
int main(){
	int n,k;
	memset(a,0,sizeof(a));
	//a[0]=0;
	//a[1]=0;
	k=0;
	for(int i=2;i<1000001;i++){
		if(a[i]==0){
			k++;
			for(int j=i;j<1000001;j=j+i)
				a[j]=k;
		}
	}
	while(scanf("%d",&n)!=EOF){
		printf("%d\n",a[n]);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章