【HDU】2016 数据的交换输出

Problem Description
输入n(n<100)个数,找出其中最小的数,将它与最前面的数交换后输出这些数。
 
Input
输入数据有多组,每组占一行,每行的开始是一个整数n,表示这个测试实例的数值的个数,跟着就是n个整数。n=0表示输入的结束,不做处理。
 
Output
对于每组输入数据,输出交换后的数列,每组输出占一行。

Sample Input
4 2 1 3 4 5 5 4 3 2 1 0
 
Sample Output
1 2 3 4 1 4 3 2 5

AC代码:

//
//  main.cpp
//  2016
//
//  Created by showlo on 2018/4/15.
//  Copyright © 2018年 showlo. All rights reserved.
//

#include <stdio.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define inf 100000

int main() {
    int a[110];
    int n,j;
    int temp;
    while (scanf("%d",&n)!=EOF&&n) {
        j=0;
        int min=inf;
        for (int i=0; i<n; i++) {
            scanf("%d",&a[i]);
            if (a[i]<min)
            {
                min=a[i];
                j=i;
            }
        }
        temp=a[j];
        a[j]=a[0];
        a[0]=temp;
        printf("%d",a[0]);
        for (int i=1; i<n; i++) {
            printf(" %d",a[i]);
        }
        printf("\n");
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章