【题解】 HDU 2602 Bone Collector

目录

题目描述

题意分析

AC代码

一维数组写法

二维数组写法


题目描述

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

 

题意分析

题意:一个喜欢收集骨头的人,现在给你N个骨头的价值以及其所占的体积,

           现在它有容量为M的口袋,问能够装入的最大价值是多少。

           典型的01揹包问题。数据中会给出一些 有价值但体积为0的数据,谨须防范

 

 

AC代码

一维数组写法

 

#include <iostream>
#include <algorithm>
#include <memory.h>
#define MAXN 10005
using namespace std;

struct infor
{
    int value;
    int volume;
}x[MAXN];

int DP[MAXN];
int main()
{
    int t,n,m,i,j;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(DP,0,sizeof(DP));
        for(i=0;i<n;i++)
        {
            cin>>x[i].value;
        }
        for(i=0;i<n;i++)
        {
            cin>>x[i].volume;
        }

        for(i=0;i<n;i++)
        {
            for(j=m;j>= x[i].volume; j--)
            {
                DP[j] = max( DP[j-x[i].volume ]+x[i].value , DP[j] );
            }
        }
        cout<<DP[m]<<endl;

    }
    return 0;
}

 

二维数组写法

 

#include <iostream>
#include <algorithm>
#include <memory.h>
#define MAXN 1005
using namespace std;

struct infor
{
    int value;
    int volume;
}x[MAXN];

int DP[MAXN][MAXN];

int main()
{
    int t,n,m,i,j;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(DP,0,sizeof(DP));
        for(i=1;i<=n;i++)
        {
            cin>>x[i].value;
        }
        for(i=1;i<=n;i++)
        {
            cin>>x[i].volume;
        }

        for(i=1;i<=n;i++)
        {
            for(j=0; j<=m; j++ )
            {
               DP[i][j] = max( DP[i-1][ j-x[i].volume ] + x[i].value , DP[i-1][j] );

               if(x[i].volume<=j && DP[i-1][j]<DP[i-1][j-x[i].volume]+x[i].value)
                    DP[i][j]=DP[i-1][j-x[i].volume]+x[i].value;
               else
                    DP[i][j]=DP[i-1][j];
            }
        }
        cout<<DP[n][m]<<endl;
    }
    return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章