PAT (Advanced Level) Practice 1143 Lowest Common Ancestor

題目描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:
For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:
6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99
Sample Output:
LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

題意

給出一顆二叉搜索樹的前序遍歷序列,求任意兩個節點的LCA。

思路

直接通過前序序列去建立二叉搜索樹會超時,因爲極端的情況下的時間複雜度會達到N^2。
所以我們可以通過前序和中序序列去建造樹,二叉搜索樹的中序序列其實就是前序序列升序排序的序列。
建完樹之後,就需要找LCA了。
找LCA我是用的暴力的方法,即先將兩個節點調到同一高度,之後再共同向上找LCA。
注意特殊情況,如果x等於y的話,則輸出x is an ancestor of x 這樣的形式。

代碼如下

#include <bits/stdc++.h>
using namespace std;
const int maxm=1005;
const int maxn=10005;
int n,m;
struct tree
{
    int left,right;
    int fa;
    int dep;
    int val;
};
int pre[maxn];
int in[maxn];
tree t[maxn];
int num=0;
int root=-1;
map<int,int>ma;
int build(int pre_left,int pre_right,int in_left,int in_right,int fa,int dep)
{
    if(pre_left>pre_right) return -1;
    //printf("pre=%d in=%d\n",pre_right-pre_left,in_right-in_left);
    int val=pre[pre_left];
    ma[val]=num;
    t[num].val=val;
    t[num].fa=fa;
    t[num].dep=dep;
    int loc=-1;
    int tnum=num;
    for (int i=in_left;i<=in_right;i++)
    {
        if(in[i]==val)
        {
            loc=i;
            break;
        }
    }
    num++;
    t[tnum].left=build(pre_left+1,pre_left+loc-in_left,in_left,loc-1,tnum,dep+1);
    t[tnum].right=build(pre_left+loc-in_left+1,pre_right,loc+1,in_right,tnum,dep+1);
    return tnum;
}
//調到同一高度後找lca
void lca(int inx,int iny,int x,int y)
{
     while(inx!=iny)
    {
        inx=t[inx].fa;
        iny=t[iny].fa;
    }
    printf("LCA of %d and %d is %d.\n",x,y,t[inx].val);
}
//使兩個節點處在同一高度
int reach_same(int inx,int iny)
{

    while(t[inx].dep>t[iny].dep)
    {
        inx=t[inx].fa;
    }
    return inx;
}
int main()
{
    memset (t,-1,sizeof(t));
    scanf("%d%d",&m,&n);
    for (int i=0;i<n;i++)
    {
        scanf("%d",&pre[i]);
        in[i]=pre[i];
    }
    sort(in,in+n);
    root=build(0,n-1,0,n-1,-1,0);
    for (int i=0;i<m;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        if(ma.find(x)==ma.end()&&ma.find(y)==ma.end())
        {
            printf("ERROR: %d and %d are not found.\n",x,y);
        }
        else if(ma.find(x)==ma.end())
        {
            printf("ERROR: %d is not found.\n",x);
        }
        else if(ma.find(y)==ma.end())
        {
            printf("ERROR: %d is not found.\n",y);
        }
        else
        {
            if(n==1)
            {
                printf("%d is an ancestor of %d.\n",in[0],in[0]);
                continue;
            }
            int inx=ma[x],iny=ma[y];
            int dx=t[inx].dep,dy=t[iny].dep;
            if(dx==dy)
            {
                lca(inx,iny,x,y);
            }
            else
            {
                if(dx>dy)
                {
                    inx=reach_same(inx,iny);
                    if(inx==iny)
                    {
                        printf("%d is an ancestor of %d.\n",y,x);
                    }
                    else
                    {
                        lca(inx,iny,x,y);
                    }
                }
                else
                {
                    iny=reach_same(iny,inx);
                    if(inx==iny)
                    {
                        printf("%d is an ancestor of %d.\n",x,y);
                    }
                    else
                    {
                        lca(inx,iny,x,y);
                    }
                }
            }
        }

    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章