Pat 1014 Waiting in Line (30)

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output “Sorry” instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
這個題是模擬進程的,然而我並不知道,我就是模擬的,用的隊列。
最坑爹的地方在最後一句話“ who cannot be served before 17:00。。。”,我一直以爲是最後的時間到了就關門,做不完拉倒,然而並不是,當時一直錯,心裏很納悶,就從網上找找,結果是自己理解錯了,然後又改,又錯了,原因是“之前”,有個before沒看見,結果又把等號去掉,結果過了。就是用隊列模擬,沒啥好說的。讀題不夠認真是真的。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
using namespace std;

struct node{
    int x,ord;
}a[1010];

int main(){

    int n,m,k,q;
    queue<node>q_line[1010];

    int len = 0;
    int peo = 0;
    int h = 8,ms = 0;
    int h_array[1010],m_array[1010];
    int s_array[1010],sm_array[1010];

    scanf("%d%d%d%d",&n,&m,&k,&q);

    for(int i = 1;i<=k||peo<k;i++){

        if(i<=k){

            scanf("%d",&a[i].x);
            a[i].ord = i;

        }

         if(len == n*m||i>k){

            int tmp;
            int a_num = 0x3f3f3f,now_number;

            for(int j = 0;j<n;j++){
                if(q_line[j].empty())continue;
                if(q_line[j].front().x < a_num){
                    now_number = j;
                    a_num  = q_line[j].front().x;
                }

            }

            ms+=a_num;
            h+=ms/60;
            ms %= 60;

            for(int j = 0;j<n;j++){
                if(q_line[j].empty())continue;
                int ord_temp = q_line[j].front().ord;

                if(j == now_number){

                   h_array[ord_temp] = h;
                   m_array[ord_temp] = ms;
                   q_line[j].pop();
                   len--;
                   peo++;
                   if(q_line[j].empty())continue;
                   s_array[q_line[j].front().ord] = h;
                   sm_array[q_line[j].front().ord] = ms;


                }else{
                    tmp = q_line[j].front().x - a_num;
                    if(tmp)q_line[j].front().x = tmp;
                    else {
                            q_line[j].pop();
                            h_array[ord_temp] = h;
                            m_array[ord_temp] = ms;
                            len--;
                            peo++;
                            if(q_line[j].empty())continue;
                            s_array[q_line[j].front().ord] = h;
                            sm_array[q_line[j].front().ord] = ms;

                    }
                }
            }
        }
        if(len < n*m && i<=k){

            int  a_line = 10010,now_line;

            for(int j = 0;j<n;j++){
                if(q_line[j].size()<a_line){
                    now_line = j;//calcute the shortest line
                    a_line = q_line[j].size();
                }
            }

            q_line[now_line].push(a[i]);

            s_array[i] = 8;
            sm_array[i] = 0;
            len++;

        }


    }
    int x;
    for(int i = 0 ;i<q;i++){
        scanf("%d",&x);
        if(s_array[x]*100 + sm_array[x] >= 1700)puts("Sorry");
        else{
            if(h_array[x]<=9)printf("0%d:",h_array[x]);
            else {
                    printf("%d:",h_array[x]);
            }

            if(m_array[x]<=9)printf("0%d\n",m_array[x]);
            else {
                    printf("%d\n",m_array[x]);
            }
        }
    }


}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章