杭電oj1236:排名(水題)

排名

題目鏈接

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程序找出最後通過分數線的考生,並將他們的成績按降序打印。

Input
測試輸入包含若干場考試的信息。每場考試信息的第1行給出考生人數N ( 0 < N< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一名考生的准考證號(長度不超過20的字符串)、該生解決的題目總數m、以及這m道題的題號(題目號由1到M)。當讀入的考生人數爲0時,輸入結束,該場考試不予處理。

Output
對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考號的升序輸出。

Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0

Sample Output
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

簡單題,一遍AC。直接上代碼

#include<iostream>
#include<algorithm>
using namespace std;

struct STU
{
	string id;//考生編號 
	int counts;//通過的課程數 
	int scores;//總成績 
}stu[1005];

bool cmp(const STU &a, const STU &b)
{
	if(a.scores != b.scores)
		return a.scores > b.scores;
	else
		return a.id < b.id;
 } 

int main()
{
	int N, M, G;
	while(cin>>N>>M>>G, N!=0)
	{
		int *score = new int[M+5];
		for(int i=1;i<=M;i++)
			cin>>score[i];
		int sum = 0, temp;
		for(int i=0;i<N;i++)
		{
			sum = 0;
			cin>>stu[i].id;
			cin>>stu[i].counts;
			for(int j=0;j<stu[i].counts;j++)
			{
				cin>>temp;
				sum += score[temp];
			}
			stu[i].scores = sum;
		}
		sort(stu, stu+N, cmp);
		//使用temp記錄過線總人數 
		temp=0;
		for(int i=0;i<N;i++)
		{
			if(stu[i].scores >= G)
				temp++;
			else
				break;
		}
		if(temp == 0)
			cout<<"0"<<endl;
		else
		{
			cout<<temp<<endl;
			for(int i=0;i<temp;i++)
				cout<<stu[i].id<<" "<<stu[i].scores<<endl;
		}
		delete []score;
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章