UVA 11020 Efficient Solutions (用multiset实现BST)

题目链接:https://cn.vjudge.net/problem/UVA-11020

“Our marriage ceremonies are solemn, sober
moments of reflection; also regret, disagreement,
argument and mutual recrimination. Once you know
it can’t get any worse, you can relax and enjoy
the marriage.”
J.Michael Straczynski, “The Deconstruction of Falling Stars.”
The princess of Centauri Prime is the galaxy’s most eligible bachelorette of the year. She has hopeful
grooms lined up in front of the royal palace for a chance to spend 5 minutes to try and impress her.
After 5 minutes, the gentleman is carried out of the royal chambers by the palace guards, and the
princess makes a decision. She rates the lad on his lineage and charm by giving him a score for each of
the two properties. On Centauri Prime, low scores are better than high scores.
Suppose that she observes two gentlemen - A and B. She assigns A the scores LA and CA (for
lineage and charm, respectively). B receives scores LB and CB. Then A is dominated by B if either
• LB < LA and CB ≤ CA, or
• LB ≤ LA and CB < CA.
In other words, if at least one of B’s scores is better than A’s, and the other score is not worse. She
considers a gentleman to be efficient (or Pareto-optimal) if she has not yet met any other gentleman who
dominates him. She maintains a list of efficient grooms and updates it after each 5-minute presentation.
Given the queue of bachelors and the scores assigned to them by the princess, determine the number
of entries in the list of efficient grooms after each performance.
Input
The first line of input gives the number of cases, N (0 < N < 40). N test cases follow.
Each one starts with a line containing n (0 ≤ n ≤ 15000) — the size of the queue. The next n lines
will each contain two scores (integers in the range [0, 109
]). Initially, the list is empty.
Output
For each test case, output one line containing ‘Case #x:’ followed by n lines, line i containing the size
of the list of efficient grooms after the i-th update. Print an empty line between test cases.
Sample Input
4
1
100 200
2
100 200
101 202
2
100 200
200 100
5
11 20
20 10
20 10
100 20
1 1
Sample Output
Case #1:
1
Case #2:
1
1
Case #3:
1
2
Case #4:
1
2
3
3
1
【中文题意】有n个人,每个人有两个属性x和y。如果对于一个人P(x,y),不存在另外一个人(x’,y’),使得x’< x,y’<=y,或者x’<=x,y’< y,我们说P是有优势的。每次给出一个人的信息,要求输出在只考虑当前已获得的信息的前期下,多少人是有优势的。
输入格式
整数T代表T组数据,每组数据一个(0<=n<=15000),一下n行,每行两个整数x,y,分别代表每个人的两个属性。
输出格式
对于每组数据,输出获得每条信息后,有优势的人数。
【分析】
我们可以看到人是只增不减的,所以当下有优势的人在以后可能会失去优势,而且一旦失去优势的话以后不会再获得优势,因此我们可以动态维护优势人群集合。
新增加一个人后会有两种情况:
1.这个点本身没有优势,可以直接忽略。
2.这个点有优势,我们把它加入到集合中,但这个点可能会使其他点失去优势,从而被删除。
这里采用STL中的multiset(可重集)来实现,因为集合中可以有完全相同的点。
【AC代码 】

#include<stdio.h>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<map>
#include<queue>
#include<stack>
#include<set>
using namespace std;
#define MAX_N 10000005
#define LL long long

struct Point
{
    int a,b;
    bool operator < (const Point & rhs)const
    {
        return a<rhs.a||(a==rhs.a&&b<rhs.b);
    }
};

multiset<Point>S;
multiset<Point>::iterator it;

int main()
{
    int T,iCase=0;
    scanf("%d",&T);
    while(T--)
    {
        int n,a,b;
        scanf("%d",&n);
        printf("Case #%d:\n",++iCase);
        S.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            Point P=(Point){a,b};
            it=S.lower_bound(P);
            if(it == S.begin()||(--it)->b > b)
            {
                S.insert(P);
                it=S.upper_bound(P);
                while(it!=S.end()&& it->b>=b)S.erase(it++);
            }
            printf("%d\n",S.size());
        }
        if(T>0)printf("\n");
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章