ZOJ 3469

When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person's coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one's Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people's Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

 

Input

 

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 231 - 1.

Please process to the end-of-file.

 

Output

 

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

 

Sample Input

 

5 1 0
1 1
2 2
3 3
4 4
5 5
 

 

Sample Output

 

55
看代碼,管它呢,據說這道題目上一次提交失敗是兩個月前的了

ZOJ

然而現在的submit按鈕徹底灰色了,連點都不能點了,升級了hh

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1003;
const int inf=0x3f3f3f3f;
struct node{
	int x,value;
}nod[maxn];
bool cmp(node a,node b){
	return a.x<b.x;
} 
int dp[maxn][maxn][2];
int sum[maxn];//
int main(){
	int n,v,x;
	while(scanf("%d%d%d",&n,&v,&x)){
//	cout<<n<<v<<x<<endl;
		//memset(sum,0)
		for(int i=1;i<=n;i++){
			scanf("%d%d",&nod[i].x,&nod[i].value);
		}
		nod[++n].x=x;
		nod[n].value=0;
		sort(nod+1,nod+n+1,cmp);int tmp;
		for(int i=1;i<=n;i++){
			if(nod[i].x==x){
				tmp=i;
				break;
			}
		}
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				dp[i][j][0]=inf;
				dp[i][j][1]=inf;
			}
		}
		for(int i=1;i<=n;i++){
			sum[i]=sum[i-1]+nod[i].value;
		}
		for(int i=tmp;i>=1;i--){
			for(int j=tmp;j<=n;j++){
				dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[i]-sum[j]+sum[n])*(nod[i+1].x-nod[i].x));
				dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[i]-sum[j]+sum[n])*(nod[j].x-nod[i].x));
				dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(sum[i-1]-sum[j-1]+sum[n])*(nod[j].x-nod[i].x));
				dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(sum[i-1]-sum[j-1]+sum[n])*(nod[j].x-nod[j-1].x));
			}
		}
	cout<<min(dp[1][n][0],dp[1][n][1])*v<<endl;
		
		
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章