PAT甲級1109 Group Photo (25分) 和乙級的1055 集體照 (25分) 模擬,稍微麻煩點

1109 Group Photo (25分)
Formation is very important when taking a group photo. Given the rules of forming K rows with N people as the following:

The number of people in each row must be N/K (round down to the nearest integer), with all the extra people (if any) standing in the last row;

All the people in the rear row must be no shorter than anyone standing in the front rows;

In each row, the tallest one stands at the central position (which is defined to be the position (m/2+1), where m is the total number of people in that row, and the division result must be rounded down to the nearest integer);

In each row, other people must enter the row in non-increasing order of their heights, alternately taking their positions first to the right and then to the left of the tallest one (For example, given five people with their heights 190, 188, 186, 175, and 170, the final formation would be 175, 188, 190, 186, and 170. Here we assume that you are facing the group so your left-hand side is the right-hand side of the one at the central position.);

When there are many people having the same height, they must be ordered in alphabetical (increasing) order of their names, and it is guaranteed that there is no duplication of names.

Now given the information of a group of people, you are supposed to write a program to output their formation.

Input Specification:
Each input file contains one test case. For each test case, the first line contains two positive integers N (≤10
​4
​​ ), the total number of people, and K (≤10), the total number of rows. Then N lines follow, each gives the name of a person (no more than 8 English letters without space) and his/her height (an integer in [30, 300]).

Output Specification:
For each case, print the formation – that is, print the names of people in K lines. The names must be separated by exactly one space, but there must be no extra space at the end of each line. Note: since you are facing the group, people in the rear rows must be printed above the people in the front rows.

Sample Input:
10 3
Tom 188
Mike 170
Eva 168
Tim 160
Joe 190
Ann 168
Bob 175
Nick 186
Amy 160
John 159
Sample Output:
Bob Tom Joe Nick
Ann Mike Eva
Tim Amy John

  • 一共N個人,K行 ,每行人數N/K 取整數
  • 後面人的身高大於等於前面人的身高
  • 每行最高的站在 (m/2+1)取整的位置 m是該行的總人數,
  • 其他人按照非增的順序進入,(我們角度看的話)先左 後後

思路

  • 使用結構體,人員信息構造成結構體,存進去vector< node > 然後sort排序
  • 每層的排序過程我們自己構造一個數組outSign,這個數組存儲0 -1 1 -2 2 -3 3 這樣的數據,那麼我們存儲時候的位置就是(m/2+1)+outSign[0] , (m/2+1)+outSign[1],(m/2+1)+outSign[3]
  • 計算第一行的個數 int firstNum=N-K*(N/K)+N/K;

AC代碼


#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

struct node
{
    string name;
    int high;

};
int  sort2(node a,node b )
{
    if(a.high!=b.high)
        return a.high>b.high;
    else
        return a.name<b.name;
}
int main()
{
    int N,K;
    cin>>N>>K;
    vector<node> vec;//保存結點信息
    for(int i=0; i<N; i++)
    {
        node a;
        cin>>a.name;
        cin>>a.high;
        vec.push_back(a);
    }
    //身高 名字 排序
    sort(vec.begin(),vec.end(),sort2);

    //規定站位
    vector<int> outSign;
    outSign.push_back(0);
    int sign=-1;
    for(int i=1; i<10000; i++)
    {
        outSign.push_back(i*sign);
        sign*=-1;
        outSign.push_back(i*sign);
        sign*=-1;
    }

    // for(int i=1; i<outSign.size(); i++)
    //    cout<<outSign[i]<<' ';

    // for(int i=0; i<N; i++)
    //     cout<<vec[i].name<<' '<<vec[i].high<<endl;
    int firstNum=N-K*(N/K)+N/K;
    int rowNum=N/K;
    int outPos=0;//記錄輸出結點數目

    for(int i=0; i<K; i++)
    {
        if(i==0)
        {
            string str[firstNum+1];
            int pos=firstNum/2+1;
            for(int n=0; n<firstNum; n++)
            {
                string name=vec[outPos++].name;
                str[pos+outSign[n]]=name;
            }
            for(int n=1; n<=firstNum; n++)
            {
                if(n==1)
                    cout<<str[n];
                else
                    cout<<' '<<str[n];
            }
            cout<<endl;
        }
        else
        {
            string str[rowNum+1];
            int pos=rowNum/2+1;
            for(int n=0; n<rowNum; n++)
            {
                string name=vec[outPos++].name;
                str[pos+outSign[n]]=name;
            }
            for(int n=1; n<=rowNum; n++)
            {
                if(n==1)
                    cout<<str[n];
                else
                    cout<<' '<<str[n];
            }
            cout<<endl;
        }
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章