PAT甲級1152 Google Recruitment (20分) 素數判斷

1152 Google Recruitment (20分)
In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越數). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404

就是給你一長串數字,和一個K,然後找出數字串中最先出現的K位素數


#include <iostream>
#include <string>
#include <vector>
#include <cmath>
using namespace std;

int isPrime(int x){
    if(x<2)
        return 0;
    for(int i=2;i<=sqrt(x);i++){
        if(x%i==0)
            return 0;
    }

    return 1;
}
int main()
{
    int N,K;
    cin>>N>>K;
    string str;
    cin>>str;
    int start=0,last=K-1;
    int outSign=0;
    while(last<str.size()){

        string sub=str.substr(start,K);
        if(isPrime(stoi(sub))){
            cout<<sub<<endl;
            outSign=1;
            break;
        }
        start++;
        last=start+K-1;

    }
    if(outSign==0)
        cout<<404;
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章