PAT甲級1147 Heaps (30分) 層數遍歷快速構建二叉樹,深搜判斷大堆 小堆

1147 Heaps (30分)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:
For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

思考:

  • 根據層序遍歷構造二叉樹的過程,我感覺使用數組要簡單點,而且題目要求的M也不大,開個大數組,下標從1表示到M,這樣結點孩子 父親的關係也就知道了,結點1的左孩子就是12 右孩子就是12+1

  • 使用一個包含結點關係的數組 進行遞歸構造二叉樹,

    void build(node *root,int pos)
    {
        if(pos*2<=M)
        {
            node *p=new node();
            p->data=sn[pos*2];
            root->lchild=p;
            build(p,pos*2);
        }
        if(pos*2+1<=M)
        {
            node *p=new node();
            p->data=sn[pos*2+1];
            root->rchild=p;
            build(p,pos*2+1);
        }
    }
    
  • 構造玩二叉樹之後就是判斷是否是大小堆,我也是用了遞歸,但是這個遞歸最終不是遇到Null返回了,遇到Null返回就太遲了,我們只是判斷結點和他左右結點的關係,所以返回條件設置成結點的左右孩子爲空。

  • 然後再寫判斷大小堆的遞歸函數後面詳細處理部分,(此時進行到這一步的root 指向的結點 左右孩子不會全爲Null) 分開處理就好了,不過也需要注意細節

    bool judgeMax(node *root)
    {
        if(root->lchild==NULL&&root->rchild==NULL)
            return 1;
        else if(root->rchild==NULL)
        {
            if(root->data>=root->lchild->data)
            {
                return judgeMax(root->lchild);
            }
            else
                return 0;
        }
        else
        {
            if(root->data>=root->lchild->data&&root->data>=root->rchild->data)
            {
                return judgeMax(root->lchild)&&judgeMax(root->rchild);
            }
            else
                return 0;
        }
    }
    

AC代碼


#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <list>
using namespace std;
struct node
{
    int data;
    node *lchild,*rchild;


};
int sn[9999];
vector<int> vec;
int N,M;
void build(node *root,int pos)
{
    if(pos*2<=M)
    {
        node *p=new node();
        p->data=sn[pos*2];
        root->lchild=p;
        build(p,pos*2);
    }
    if(pos*2+1<=M)
    {
        node *p=new node();
        p->data=sn[pos*2+1];
        root->rchild=p;
        build(p,pos*2+1);
    }
}
void df(node *root)
{
    if(root==NULL)
        return;
    df(root->lchild);
    df(root->rchild);
    vec.push_back(root->data);
}
bool judgeMax(node *root)
{
    if(root->lchild==NULL&&root->rchild==NULL)
        return 1;
    else if(root->rchild==NULL)
    {
        if(root->data>=root->lchild->data)
        {
            return judgeMax(root->lchild);
        }
        else
            return 0;
    }
    else
    {
        if(root->data>=root->lchild->data&&root->data>=root->rchild->data)
        {
            return judgeMax(root->lchild)&&judgeMax(root->rchild);
        }
        else
            return 0;
    }
}
bool judgeMin(node *root)
{
    if(root->lchild==NULL&&root->rchild==NULL)
        return 1;
    else if(root->rchild==NULL)
    {
        if(root->data<=root->lchild->data)
        {
            return judgeMax(root->lchild);
        }
        else
            return 0;
    }
    else
    {
        if(root->data<=root->lchild->data&&root->data<=root->rchild->data)
        {
            return judgeMin(root->lchild)&&judgeMin(root->rchild);
        }
        else
            return 0;
    }
}

int main()
{

    cin>>N>>M;
    for(int q=0; q<N; q++)
    {
        fill(sn,sn+9999,0);

        for(int i=1; i<=M; i++)
        {
            cin>>sn[i];
        }
        node *root=new node();
        root->data=sn[1];
        build(root,1);
        df(root);
        bool maxx=judgeMax(root);
        bool minn=judgeMin(root);
        if(maxx)
            cout<<"Max Heap"<<endl;
        else if(minn)
            cout<<"Min Heap"<<endl;
        else
            cout<<"Not Heap"<<endl;

        for(int i=0; i<vec.size(); i++)
        {
            if(i==0)
                cout<<vec[i];
            else
                cout<<' '<<vec[i];
        }
        cout<<endl;
        vec.clear();
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章