PAT甲級1133 Splitting A Linked List (25分) 簡單題 ,list刪除

1133 Splitting A Linked List (25分)
Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤10
​3
​​ ). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next
where Address is the position of the node, Data is an integer in [−10
​5
​​ ,10
​5
​​ ], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:
For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218
Sample Output:
33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

就是給了一個鏈表,按照負數調在前面,0-K 在中的 順序調整,我第一想法是構建一個lsit< node > 然後再這個list表先提取負數,再提取0-k之間的數,剩下的順序不變

幾個關鍵的點

  • 如何保存輸入給的結點信息,我是用了兩個map 映射,根據pos 映射對應的data和next,也可以直接使用一個node數組,都行

    struct node {
        int data, next;
    }list[100000];
    
  • 如何將保存的結點信息構造出來,我是用的list< node > ,看了別人的代碼感覺更好的辦法是建立三個vector< node > 根據data小於0 大於0小於K 大於K 分別保存,這樣提取時候也簡單,如果使用list 的提取就需要進行三次,每次提取之後使用erase(it++) 刪除對應的結點


#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <list>
using namespace std;
struct node
{
    int posl;
    int data;
    int next;

};

int main()
{
    int pos,N,K;
    cin>>pos>>N>>K;
    vector<node> nodeSave;
    unordered_map<int,int> map_data;
    unordered_map<int,int> map_next;

    for(int i=0; i<N; i++)
    {
        node a;
        cin>>a.posl>>a.data>>a.next;
        map_data[a.posl]=a.data;
        map_next[a.posl]=a.next;
    }

    list<node> listt;
    while(pos!=-1)
    {
        node a;
        a.posl=pos;
        a.data=map_data[pos];
        a.next=map_next[pos];
        pos=a.next;
        listt.push_back(a);
    }
    vector<node> out;
    for(auto it=listt.begin(); it!=listt.end();)
    {
       // cout<<(*it).posl<<' '<<(*it).data<<endl;
        if((*it).data<0)
        {
            out.push_back(*it);
            listt.erase(it++);// 後面的++很關鍵
        }
        else
            it++;
    }
    for(auto it=listt.begin(); it!=listt.end();)
    {
       // cout<<(*it).posl<<' '<<(*it).data<<endl;
        if((*it).data<=K)
        {
            out.push_back(*it);
            listt.erase(it++);// 後面的++很關鍵
        }
        else
            it++;
    }
    for(auto it=listt.begin(); it!=listt.end();it++)
    {

            out.push_back(*it);

    }
    //cout<<out[0].posl;
    for(int i=0;i<out.size();i++){
        if(i==0){
            printf("%05d %d ",out[i].posl,out[i].data);
        }
        else{
            printf("%05d\n%05d %d ",out[i].posl,out[i].posl,out[i].data);

        }
    }
    cout<<-1;
    return 0;
}


更好辦法柳神:https://blog.csdn.net/liuchuo/article/details/78037305

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章