PAT甲級1154 Vertex Coloring (25分) 簡單題讀懂題目就好

1154 Vertex Coloring (25分)
A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10
​4
​​ ), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:
For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No

就是N個頂點,編號從0到N-1,然後給出M條邊,用兩端頂點表示。 如果沒有共享同一條邊的兩個頂點顏色一樣的 頂點圖就稱之爲 k-coloring.

set判斷K是多少,每個頂點圖 過一遍所有的邊就搞定了

#include <iostream>
#include <algorithm>
using namespace std;
#include <vector>
#include <unordered_set>





int main()
{
    int N,M;
    cin>>N>>M;
    int vertex[N];
    int edge[M][2];
    for(int i=0; i<M; i++)
    {
        cin>>edge[i][0]>>edge[i][1];
    }
    int num;
    cin>>num;
    for(int i=0; i<num; i++)
    {
        unordered_set<int> sett;
        for(int q=0; q<N; q++)
        {
            cin>>vertex[q];
            sett.insert(vertex[q]);
        }
        //對頂點進行判斷
        int sign=1;
        for(int i=0; i<M; i++)
        {
            int a=edge[i][0];
            int b=edge[i][1];
            if(vertex[edge[i][0]]==vertex[edge[i][1]]){
                sign=0;
                break;
            }
        }
        if(sign==0){
            cout<<"No"<<endl;
        }
        else{
            cout<<sett.size()<<"-coloring"<<endl;
        }
    }

    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章