PAT甲級1053 Path of Equal Weight (30分)

1053 Path of Equal Weight (30分)
Given a non-empty tree with root R, and with weight W
​i
​​ assigned to each tree node T
​i
​​ . The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2
​30
​​ , the given weight number. The next line contains N positive numbers where W
​i
​​ (<1000) corresponds to the tree node T
​i
​​ . Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A
​1
​​ ,A
​2
​​ ,⋯,A
​n
​​ } is said to be greater than sequence {B
​1
​​ ,B
​2
​​ ,⋯,B
​m
​​ } if there exists 1≤k<min{n,m} such that A
​i
​​ =B
​i
​​ for i=1,⋯,k, and A
​k+1
​​ >B
​k+1
​​ .

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

思路還是很簡單的,深度搜索搞定,不過需要注意邊如何保存,以及如何判斷葉子節點,結果如何保存,結果如何排序

使用vector<vector >vec(101)來存儲邊,權重使用int weight[101]存儲。搜索時候使用一個vector out, 先把根節點0存進去,然後權重值減去根節點的權重,調用df算法。葉子結點判斷可以使用vec[節點編號].size()==0
排序可以使用自己寫一個sort排序

#include <iostream>
#include <algorithm>
using namespace std;
#include <vector>




vector<vector<int>> edge(101);

int weight[101];
vector<int> out;
vector<vector<int>> beforSort;
void df(int root,int lastSum)
{
    if(lastSum==0&&edge[root].size()==0)
    {
        beforSort.push_back(out);
        return ;
    }
    else if(lastSum<0)
    {
        return;
    }
    else
    {
        for(int i=0;i<edge[root].size();i++){
            out.push_back(edge[root][i]);
            df(edge[root][i],lastSum-weight[edge[root][i]]);
            out.pop_back();
        }
    }

}
bool sort2(vector<int> a,vector<int> b ){

    int i=0;
    while(i<a.size()&&i<b.size()){
        int aa=weight[a[i]],bb=weight[b[i]];
        if(aa>bb){
            return 1;
        }
        else if(aa<bb)
            return 0;
        i++;
    }
    return 0;
}
int main()
{
int N,inNum,SUM;
    cin>>N>>inNum>>SUM;

    for(int i=0; i<N; i++)
    {
        cin>>weight[i];
    }
    for(int i=0; i<inNum; i++)
    {
        int parent;
        cin>>parent;
        int k;
        cin>>k;
        for(int p=0; p<k; p++)
        {
            int son;
            cin>>son;
            edge[parent].push_back(son);
        }
    }
    //0是根節點
    out.push_back(0);
    df(0,SUM-weight[0]);

    sort(beforSort.begin(),beforSort.end(),sort2);
    //輸出vec元素對應的weight
    for(int q=0;q<beforSort.size();q++){
        for(int i=0;i<beforSort[q].size();i++){
            if(i==0){
                cout<<weight[beforSort[q][i]];
            }
            else{
                cout<<' '<<weight[beforSort[q][i]];
            }
        }
        cout<<endl;
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章