A. Letter Combinations of a Phone Number

Given a string containing digits from 2-9 inclusive, return all possible letter combinations that the number could represent.

A mapping of digit to letters (just like on the telephone buttons) is given below. Note that 1 does not map to any letters.

Sample Input

23

Sample Output

ad
bd
cd
ae
be
ce
af
bf
cf

Hint

the above answer is in lexicographical order, please output in the same order!

我的做法:

import java.util.Scanner;

public class Main {
	public static void main(String [] args) throws Exception {
		Scanner sc = new Scanner(System.in); 
		String str = sc.nextLine();
		char[] arr = str.toCharArray();
		int n = arr.length;
		String [][]a = new String[n][5];
		int num[] = new int[n];
		for(int i=0;i<arr.length;i++){
			if(arr[i] == '2'){
				num[i] = 3;
				a[i][1]="a";
				a[i][2]="b";
				a[i][3]="c";
				a[i][4]="*";
			}
			if(arr[i] == '3'){
				num[i] = 3;
				a[i][1]="d";
				a[i][2]="e";
				a[i][3]="f";
				a[i][4]="*";
			}
			if(arr[i] == '4'){
				num[i] = 3;
				a[i][1]="g";
				a[i][2]="h";
				a[i][3]="i";
				a[i][4]="*";
			}
			if(arr[i] == '5'){
				num[i] = 3;
				a[i][1]="j";
				a[i][2]="k";
				a[i][3]="l";
				a[i][4]="*";
			}
			if(arr[i] == '6'){
				num[i] = 3;
				a[i][1]="m";
				a[i][2]="n";
				a[i][3]="o";
				a[i][4]="*";
			}
			if(arr[i] == '7'){
				num[i] = 4;
				a[i][1]="p";
				a[i][2]="q";
				a[i][3]="r";
				a[i][4]="s";
			}
			if(arr[i] == '8'){
				num[i] = 3;
				a[i][1]="t";
				a[i][2]="u";
				a[i][3]="v";
				a[i][4]="*";
			}
			if(arr[i] == '9'){
				num[i] = 4;
				a[i][1]="w";
				a[i][2]="x";
				a[i][3]="y";
				a[i][4]="z";
			}
		}
		int number = 1;
		for(int i=0;i<n;i++){
			number = number*num[i];
		}
		//System.out.println(number);
		String []out = new String[number];
		for(int i=0;i<number;i++){
			out[i] = "";
		}
		int m = 0;
		for(int i=0;i<number;i++){

			out[i] = out[i]+a[m][1]; 
			i++;
			out[i] = out[i]+a[m][2]; 
			i++;
			out[i] = out[i]+a[m][3];
			if(a[m][4]!="*"){
				i++;
				out[i] = a[m][4];
			}
		}
		m++;
		
		while(m<n){
			int k=1;
			for(int i=0;i<m;i++){
				if(arr[i]=='7'||arr[i]=='9'){
					k = k*4;
				}else {
					k = k*3;
				}
			    
			}
			//System.out.println(k);
			for(int i=0;i<number;){
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][1]; 
					i++;
				}
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][2]; 
					i++;
				}
				for(int j=0;j<k;j++){
					out[i] = out[i]+a[m][3]; 
					i++;
				}
				
				if(a[m][4]!="*"){
					for(int j=0;j<k;j++){
						out[i] = out[i]+a[m][4]; 
						i++;
					}
				}
			}
			m++;
		}
		for(int i=0;i<number;i++){
			System.out.println(out[i]);
		}		
	}
}

同學易浩的做法:

import java.util.Scanner;


public class Main{
	public static void main(String[] args){
		Scanner sc = new Scanner(System.in);
		String s = sc.nextLine();
		String[][] map = {{"a","b","c"},{"d","e","f"},{"g","h","i"},{"j","k","l"},{"m","n","o"},{"p","q","r","s"},{"t","u","v"},{"w","x","y","z"}};
		int [] index = new int[s.length()];
		for(int i=0;i<s.length();i++){
			index[i] = (s.charAt(i)-'0');
		}
		String[] result;
		if(index.length==1){
			result = map[index[0]-2];
		}
		else if(index.length==2){
			result = fun(map[index[0]-2],map[index[1]-2]);
		}
		else{
			int n = index.length;
			result = fun(map[index[n-2]-2],map[index[n-1]-2]);
			for(int i=index.length-3;i>=0;i--){
				String []tmp = map[index[i]-2];
				result = fun(tmp,result);
			}
		}
		for(int i=0;i<result.length;i++){
			System.out.println(result[i]);
		}

	}
	
	public static String[] fun(String[] tmp,String[] tmp1){
		String [] result = new String[tmp1.length*tmp.length];
		for(int i=0;i<tmp1.length;i++){
			for(int j=0;j<tmp.length;j++){
				result[i*tmp.length+j]= tmp[j]+tmp1[i];
			}
		}
		return result;
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章