hdu 5073 Galaxy

Galaxy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 323    Accepted Submission(s): 71
Special Judge


Problem Description
Good news for us: to release the financial pressure, the government started selling galaxies and we can buy them from now on! The first one who bought a galaxy was Tianming Yun and he gave it to Xin Cheng as a present.


To be fashionable, DRD also bought himself a galaxy. He named it Rho Galaxy. There are n stars in Rho Galaxy, and they have the same weight, namely one unit weight, and a negligible volume. They initially lie in a line rotating around their center of mass.

Everything runs well except one thing. DRD thinks that the galaxy rotates too slow. As we know, to increase the angular speed with the same angular momentum, we have to decrease the moment of inertia.

The moment of inertia I of a set of n stars can be calculated with the formula


where wi is the weight of star i, di is the distance form star i to the mass of center.

As DRD’s friend, ATM, who bought M78 Galaxy, wants to help him. ATM creates some black holes and white holes so that he can transport stars in a negligible time. After transportation, the n stars will also rotate around their new center of mass. Due to financial pressure, ATM can only transport at most k stars. Since volumes of the stars are negligible, two or more stars can be transported to the same position.

Now, you are supposed to calculate the minimum moment of inertia after transportation.
 

Input
The first line contains an integer T (T ≤ 10), denoting the number of the test cases.

For each test case, the first line contains two integers, n(1 ≤ n ≤ 50000) and k(0 ≤ k ≤ n), as mentioned above. The next line contains n integers representing the positions of the stars. The absolute values of positions will be no more than 50000.
 

Output
For each test case, output one real number in one line representing the minimum moment of inertia. Your answer will be considered correct if and only if its absolute or relative error is less than 1e-9.
 

Sample Input
2 3 2 -1 0 1 4 2 -2 -1 1 2
 

Sample Output
0 0.5
 

Source
 


題解及代碼:


        現場賽的時候,以爲是一個貪心,策略搞了半天,也沒能ac,絕望之時把o(nk)的暴力對拍程序交了一發,ac了.....無語,可能是時限開的比較大的緣故吧。

        之後推了推公式,發現是一個非常簡單的數學題目,只要o(n)的複雜度就可以了。

        推導過程見:點擊打開鏈接


#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
long long s[50050];
//對拍程序,請忽略
void solve(int n,int k)
{
    double sum=0;
    for(int i=1;i<=k;i++)
    {
        sum+=s[i];
    }
    int l=1,r=k;
    double ans=-1;
    for(int i=k;i<=n;i++)
    {
        double avg=sum/k,t=0;
        for(int j=l;j<=r;j++)
        {
            t+=(s[j]-avg)*(s[j]-avg);
        }
        l++,r++;
        sum=sum-s[l-1]+s[r];
        if(i==k||ans>t) ans=t;
    }
    printf("%.12lf\n",ans);
}

int main()
{

    int cas,n,k;
    scanf("%d",&cas);
    while(cas--)
    {
        long long suml=0,sumr=0,ans=-1,t=0;
        scanf("%d%d",&n,&k);
        k=n-k;
        for(int i=1;i<=n;i++)
        {
            scanf("%I64d",&s[i]);
        }
        if(k==0||k==1)
        {
            printf("0.000000000000\n");
            continue;
        }
        s[n+1]=0;
        sort(s+1,s+n+1);
        for(int i=1;i<=k;i++)
        {
            suml=suml+s[i],sumr=sumr+s[i]*s[i];
        }
        for(int i=k;i<=n;i++)
        {
            t=sumr*k-suml*suml;
            if(i==k||ans>t) ans=t;
            suml=suml-s[i-k+1]+s[i+1];
            sumr=sumr-s[i-k+1]*s[i-k+1]+s[i+1]*s[i+1];
        }
        //solve(n,k);
        printf("%.12lf\n",(double)ans/(double)k);
    }
    return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章