POJ2488 Knight's Journey 深搜DFS

A Knight's Journey

 

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

題意:在給定的p*q的國際棋盤上,任選一個起點,以馬走日的跳法不重複地走遍棋盤上的所有方格。棋盤行號爲數字,列號爲字母,給出字典序最小的路徑。

分析:本題關鍵在於求出字典序最小的路徑,所以應從A1點開始進行DFS。對於各位置8個可以移動的方向應該從左至右,從上到下依次搜索,以確定字典序最小。

#include<iostream>
#include<cstring>
#include<vector>
#include<utility>
using namespace std;
int P,Q,dir[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},
		{1,-2},{1,2},{2,-1},{2,1}};//方向按從左至右,從上至下依次搜索 
bool vis[26][26];
vector<pair<int,int> >path;//存儲已走的路徑 

bool dfs(int x,int y)
{
	vis[x][y]=true;
	path.push_back(make_pair(x,y));
	
	if(path.size()==P*Q) return true;//已走遍棋盤上所有方格
	
	for(int i=0;i<8;i++)
	{
		int nx=x+dir[i][0],ny=y+dir[i][1];
		if(nx>=0&&nx<Q&&ny>=0&&ny<P&&!vis[nx][ny])
		{
			if(dfs(nx,ny))
				return true;
		}
	}
    //不能走遍則改變當前路徑
	vis[x][y]=false;
	path.pop_back();
	return false;
}

int main()
{
	int n,k=1;
	cin>>n;
	while(n--)
	{
		memset(vis,0,sizeof(vis));
		path.clear();
		
		cin>>P>>Q;
		printf("Scenario #%d:\n",k++);
		if(!dfs(0,0))//從A1方格開始搜索 
		{
			cout<<"impossible"<<endl;
		}
		else
		{
			for(int i=0;i<path.size();i++)
			{
				int x=path[i].first,y=path[i].second;
				cout<<(char)('A'+x)<<(y+1);
			}
			cout<<endl;
		}
		cout<<endl;
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章