HDU1032--The 3n + 1 problem

The 3n + 1 problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21037    Accepted Submission(s): 7857


Problem Description
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm: 


    1.      input n

    2.      print n

    3.      if n = 1 then STOP

    4.           if n is odd then n <- 3n + 1

    5.           else n <- n / 2

    6.      GOTO 2


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1 

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.) 

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16. 

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j. 
 

Input
The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0. 

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j. 

You can assume that no opperation overflows a 32-bit integer.
 

Output
For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line). 
 

Sample Input
1 10 100 200 201 210 900 1000
 

Sample Output
1 10 20 100 200 125 201 210 89 900 1000 174
 

解析:這道題是經典的水題,來自古老的UVaOnlineJudge,且這道題不涉及溢出的情況,題目中說了,可以假設在int的範圍內,如果沒有這句話一定要考慮到中間溢出的情況,另外UVa上好多題目都是沒有指定順序,輸入i,j可能i<j也可能是i>j,但是輸出的時候還得原樣輸出,所以在UVa上做題一定要考慮到這點,並且最坑的是它的測試數據根本不提示這個情況,唉……
總體來說水題,貼下代碼哈

#include <iostream>
using std::endl;
using std::cin;
using std::cout;
int fun(int num)
{
	int count = 1;
	while(num >1)
	{
		if(num%2 == 0)
		{
			num/=2;
		}else{
			num = num*3+1;
		}
		count ++;
	}
	return count;
}
int main()
{
#ifdef LOCAL
	freopen("input.txt" , "r" , stdin);
	//freopen("output.txt" , "w" , stdout);
#endif
	int i , j;
	while(cin >> i >> j)
	{
		int a=i , b=j;
		if(i>j)
		{
			a = j;
			b = i;
		}
		int maxlength = 1;
		for(int k=a; k<=b; ++k)
		{
			int cnt = fun(k);
			if(cnt > maxlength)
				maxlength = cnt;
		}
		cout << i << " "<< j <<" " << maxlength << endl;
	}
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章