HDU3779Railroad DP 記憶化搜索

Railroad

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 938    Accepted Submission(s): 386


Problem Description
A train yard is a complex series of railroad tracks for storing, sorting, or loading/unloading railroad cars. In this problem, the railroad tracks are much simpler, and we are only interested in combining two trains into one.

Figure 1: Merging railroad tracks.


The two trains each contain some railroad cars. Each railroad car contains a single type of products identified by a positive integer up to 1,000,000. The two trains come in from the right on separate tracks, as in the diagram above. To combine the two trains, we may choose to take the railroad car at the front of either train and attach it to the back of the train being formed on the left. Of course, if we have already moved all the railroad cars from one train, then all remaining cars from the other train will be moved to the left one at a time. All railroad cars must be moved to the left eventually. Depending on which train on the right is selected at each step, we will obtain different arrangements for the departing train on the left. For example, we may obtain the order 1,1,1,2,2,2 by always choosing the top train until all of its cars have been moved. We may also obtain the order 2,1,2,1,2,1 by alternately choosing railroad cars from the two trains.

To facilitate further processing at the other train yards later on in the trip (and also at the destination), the supervisor at the train yard has been given an ordering of the products desired for the departing train. In this problem, you must decide whether it is possible to obtain the desired ordering, given the orders of the products for the two trains arriving at the train yard.
 

Input
The input consists of a number of cases. The first line contains two positive integers N1 N2 which are the number of railroad cars in each train. There are at least 1 and at most 1000 railroad cars in each train. The second line contains N1 positive integers (up to 1,000,000) identifying the products on the first train from front of the train to the back of the train. The third line contains N2 positive integers identifying the products on the second train (same format as above). Finally, the fourth line contains N1+N2 positive integers giving the desired order for the departing train (same format as above).

The end of input is indicated by N1 = N2 = 0.
 

Output
For each case, print on a line possible if it is possible to produce the desired order, or not possible if not.
 

Sample Input
3 3 1 2 1 2 1 1 1 2 1 1 2 1 3 3 1 2 1 2 1 2 1 1 1 2 2 2 0 0
 

Sample Output
possible not possible
 


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>

using namespace std;

int a[1009],b[1009],c[3009];//注意C數組的大小
int dp[2009][2009];
  int N,M;

int dfs(int n,int m,int k)
{
    if(k==M+N-1) return 1;
    if(dp[n][m])return 0;
    dp[n][m]=1;  //標記該狀態已經到過,但是後來沒有得到結果所以不必繼續

    if(a[n]==c[k] && dfs(n+1,m,k+1))return 1;
    if(b[m]==c[k] && dfs(n,m+1,k+1))return 1;

    return 0;
}

int main()
{

    while(~scanf("%d%d",&N,&M))
    {
        if(M==0 && N==0) break;
        for(int i=0;i<N;i++)
            scanf("%d",&a[i]);
            a[N]=-1;

        for(int i=0;i<M;i++)
            scanf("%d",&b[i]);
            b[M]=-1;

        for(int i=0;i<N+M;i++)
            scanf("%d",&c[i]);

            memset(dp,0,sizeof dp);

        if(dfs(0,0,0))
            puts("possible");
        else
            puts("not possible");

    }
    return 0;
}


//dp[i][j]表示第一串的取前i個,第二串取前j個
#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>

using namespace std;

int a[1009],b[1009],c[3009];//注意C數組的大小
int dp[2009][2009];
  int N,M;

int main()
{
    while(~scanf("%d%d",&N,&M))
    {
        if(M==0 && N==0) break;
        for(int i=1;i<=N;i++)
            scanf("%d",&a[i]);
           // a[N]=-1;

        for(int i=1;i<=M;i++)
            scanf("%d",&b[i]);
           // b[M]=-1;

        for(int i=1;i<=N+M;i++)
            scanf("%d",&c[i]);

            memset(dp,0,sizeof dp);
            dp[0][0]=1;
            for(int i=0;i<=N;i++)
            {
                for(int j=0;j<=M;j++)
                {
                    if(i==0 && j==0)continue;
                    if(i>0 && a[i]==c[i+j] && dp[i-1][j])
                        dp[i][j]=1;
                    if(j>0 && b[j]==c[i+j] && dp[i][j-1])
                        dp[i][j]=1;
                }
            }

            if(dp[N][M])
            {
                puts("possible");
            }
            else
            {
                 puts("not possible");
            }

    }
    return 0;
}


















發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章