HDUOJ 1004 Let the Balloon Rise

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

題意大概就是輸出出現次數最多的顏色

#include <cstdio>
#include <cstring>
#include <map>
#include <string>
#include <iostream>

using namespace std;

const int MAX = 1e5 + 9;

int a[MAX];
int n;

int main()
{
    while(scanf("%d", &n) && n)
    {
        string color;
        map<string, int> m;
        for(int i = 0; i < n; i++)
        {
            cin >> color;
            m[color] ++;
        }

        map<string, int>::iterator it, ans;
        int maxx = -1;

        for(it = m.begin(); it != m.end(); it++)
        {
            if((*it).second > maxx)
            {
                ans = it;
                maxx = (*it).second;
            }
        }

        cout << (*ans).first << endl;
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章