HDUOJ 2199 Can you solve this equation?

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

二分

#include <cstdio>
#include <cstring>
#include <map>
#include <string>
#include <iostream>

using namespace std;

const int MAX = 19;

int T, Y;

double func(double x)
{
    return 8 * x * x * x * x + 7 * x * x * x + 2 * x * x
           +  3 * x + 6 ;
}

int main()
{
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &Y);
        double l, r, mid;
        l = 0.0;
        r = 100.0;

        while( r - l > 1e-6)
        {
            mid = (l + r) / 2;
            if(func(mid) < Y)
                l = mid;
            else if(func(mid > Y))
                r = mid;
            else
                break;
        }
        if(Y < func(0) || Y > func(100))
            printf("No solution!\n");
        else
            printf("%.4f\n", mid);
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章