hdu3047-帶權並查集

題目:

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3974    Accepted Submission(s): 1519


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case:
Output R, represents the number of incorrect request.
 

Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
2


題意:給你兩個人a,b和一個距離x要求b坐在a的右邊距離x遠的位置,給出一系列的安排座位的指令,問你有幾個指令是不合法的(即與之前的已有的安排有衝突的).

思路:用一個dis數組存該點與根結點的距離,那麼在合併兩個人時有兩種情況,1:他們已經在同一集合,那麼只要判斷他們現有的dis之差是否等於x。2:他們不在同一集合,那麼更新dis數組的值,並將b所在集合放入a中。

代碼:

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
const int maxn=111111;
using namespace std;

int f[maxn],dis[maxn];
int n,m;
int a,b,x;
int ans;

int Get_f(int v)
{
    if(f[v]==v)
        return v;
    int fa=f[v];
    f[v]=Get_f(f[v]);
    dis[v]=dis[v]+dis[fa];
    return f[v];
}

int Merge(int v,int u)
{
    int vv=Get_f(v);
    int uu=Get_f(u);
    if(vv==uu)
    {
        if(dis[u]-dis[v]!=x)
            ans++;
    }
    else
    {
        f[uu]=vv;
        dis[uu]=dis[v]+x-dis[u];
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=0;
        for(int i=1;i<=n;i++)
        {
            f[i]=i;
            dis[i]=0;
        }
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&x);
            Merge(a,b);
            /*for(int j=1;j<=10;j++)
            {
                 printf("f%d:%d   dis%d : %d\n",j,f[j],j,dis[j]);
            }
            printf(" ans:%d\n",ans);*/
        }
        printf("%d\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章