找出現次數最多的數-Ignatius and the Princess IV

Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output

For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input

5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output

3 5 1
 

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    while(1)
    {
        int i,b,max=1;
        long long n;
        cin>>n;
        int a[n];
        memset(a,0,sizeof(a));
        for(i=1; i<=n; i++)
        {
            cin>>b;
            a[b]++;
            if(b>max)
                max=b;
        }
        b=a[1];
        for(i=2; i<=max; i++)
        {
            if(a[i]>b)
                b=a[i];
        }
        for(i=1; i<=max; i++)
        {
            if(a[i]==b)
                cout<<i<<endl;
        }
    }
    return 0;
}


用數組做時提示runtime error,可能是越界了。


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章