TOJ 3517 The longest athletic track

After a long time of algorithm training, we want to hold a running contest in our beautiful campus. Because all of us are curious about a coders's fierce athletic contest,so we would like a more longer athletic track so that our contest can last more .


In this problem, you can think our campus consists of some vertexes connected by roads which are undirected and make no circles, all pairs of the vertexes in our campus are connected by roads directly or indirectly, so it seems like a tree, ha ha.


We need you write a program to find out the longest athletic track in our campus. our athletic track may consist of several roads but it can't use one road more than once.

Input

*Line 1: A single integer: T represent the case number T <= 10
For each case
*Line1: N the number of vertexes in our campus 10 <= N <= 2000
*Line2~N three integers a, b, c represent there is a road between vertex a and vertex b with c meters long
1<= a,b <= N,  1<= c <= 1000;

Output

For each case only one integer represent the longest athletic track's length

Sample Input

1
7
1 2 20
2 3 10
2 4 20
4 5 10
5 6 10
4 7 40

Sample Output

80

分析:求樹的直徑(最長路)的模板題。


Code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#define Max(a,b) ((a)>(b)?(a):(b))
using namespace std;

const int maxn=2005;
const int inf=0x3f3f3f3f;
int Map[maxn][maxn],sum[maxn];
bool vis[maxn];
int ans,n;

int bfs(int st) {
    memset(vis,false,sizeof(vis));
    vis[st]=true;
    sum[st]=0;
    queue<int>Q;
    Q.push(st);
    ans=0;
    int key;
    while(!Q.empty()) {
        int cur=Q.front();
        Q.pop();
        for(int i=1;i<=n;i++) {
            if(!vis[i]&&Map[cur][i]<inf) {
                vis[i]=true;
                sum[i]=sum[cur]+Map[cur][i];
                Q.push(i);
                if(sum[i]>ans) {
                    ans=sum[i];
                    key=i;
                }
            }
        }
    }
    return key;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--) {
        scanf("%d",&n);
        for(int i=1;i<=n;i++) {
            Map[i][i]=inf;
            for(int j=i+1;j<=n;j++) Map[i][j]=Map[j][i]=inf;
        }
        int u,v,w;
        for(int i=1;i<n;i++) {
            scanf("%d %d %d",&u,&v,&w);
            Map[u][v]=Map[v][u]=w;
        }
        int p=bfs(1);
        bfs(p);
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章