POJ 2528 - Mayor's posters(模擬)

Mayor’s posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 60890 Accepted: 17606
Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,… , ri.
Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

這裏寫圖片描述

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output

4

題意:
給出n個海報粘到牆上,問最後能看到多少張海報(部分看到也算)。

解題思路:
線段樹區間更新。
用模擬也可過,因爲是後來的覆蓋之前的,那麼對於同一區域,後來的必然能看見。
那麼就逆序遍歷,如果之前沒有覆蓋,那麼就把這一區域標記成海報右端的位置。
這樣下次如果看到此區域,那麼直接跳轉到海報的最右端,從最右端開始,看能否進行覆蓋。
對於每一個海報,只要有覆蓋的操作,那麼必然有這一部分能被看見。

AC代碼:

#include<stdio.h>
#include<string.h>
int l[10005];
int r[10005];
int a[10000005];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(int i = 1;i <= n;i++)   scanf("%d%d",&l[i],&r[i]);
        int ans = 0;
        for(int i = n;i >= 1;i--)
        {
            int flag = 0;
            for(int j = l[i];j <= r[i];j++)
            {
                if(!a[j])   a[j] = r[i],flag = 1;
                else        j = a[j];
            }
            ans += flag;
        }
        printf("%d\n",ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章