Vuex安裝、運行報錯及解決辦法

1.使用Vue2中安裝vuex的時候,輸入npm install vuex --save;出現如下報錯。

 

 


發現是版本問題。

2022年2月7日,vue3就成爲了默認版本。並且vue3成爲默認版本的同時,vuex也更新到了4版本。也就是,現在如果執行npm i vuex,安裝的就是vuex4了。

而vuex的4版本只能在vue3中使用。如果我們非要在vue2的項目當中使用vuex的4版本,就會出現如上圖所示的報錯。

匹配規則如下:

 (1)Vue2中,要用vuex的3版本;

 (2)Vue3中,要用vuex的4版本。

那麼,我現在用的是vue2,要安裝vuex的3版本;

安裝vuex就需要指定版本,即:npm i [email protected]。如下圖所示,安裝插件vuex成功。

 

 



2.vuex運行錯誤

import Vuex from 'vuex'


查找發現,是字母大小寫的問題,值得注意,因爲經常會犯這種低級的錯誤。
修改完成之後,就正常運行了。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章