Hdu1240 Asteroids!(BFS) ---Java版

Asteroids!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5026 Accepted Submission(s): 3231


Problem Description
You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.


Output
For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.


Sample Input
START 1 O 0 0 0 0 0 0 END START 3 XXX XXX XXX OOO OOO OOO XXX XXX XXX 0 0 1 2 2 1 END START 5 OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO XXXXX XXXXX XXXXX XXXXX XXXXX OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO OOOOO 0 0 0 4 4 4 END

Sample Output
1 0 3 4 NO ROUTE


題意: 輸入一個三維地圖,三維皆爲n,然後輸入起點和終點座標,求起點到終點的步數,如果不能到達則輸出”NO ROUTE“。


思路:三維看起來雖然比較複雜,但其實能寫出走法和約束規則,就沒有什麼大問題了。這裏要注意的是輸入座標分別爲y、x、z,還有,Java中三維不能像C一樣賦值,如果要在定義時賦值則要有與維數相同的括號(之前用得少,不清楚)。方向數組就算一開始不能確定具體大小也沒關係,先看走法,一共六個方向,每次只能走一步,所以共有2+2+2種走法,所以6 1 3,6表示方向,1表示每個方向具體,3表示每個座標具體。


import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
         Scanner sc = new Scanner(System.in);
         
         while(sc.hasNext()){
        	 String str = sc.next();
        	 int n = sc.nextInt();
        	 char [][][]map = new char[n][n][n];
        	 boolean [][][] vis = new boolean[n][n][n];
        	 for(int i=0;i<n;i++){
        		 for(int j=0;j<n;j++){
        			String str2 = sc.next();  
        			 for(int k=0;k<n;k++){
        				 map[i][j][k] = str2.charAt(k);
        			 }
        		 }
        	 }
        	 Points st = new Points();
        	 Points ed = new Points();
        	 
        	 st.y = sc.nextInt();
        	 st.x = sc.nextInt();
        	 st.z = sc.nextInt();
        	 ed.y = sc.nextInt();
        	 ed.x = sc.nextInt();
        	 ed.z = sc.nextInt();
        	 st.step=0;
        	 ed.step=0;
        	
        	 String str2 = sc.next();
        	 
        	 int result = bfs(n,st,ed,map,vis);
        	 if(result==-1){
        		 System.out.println("NO ROUTE");
        	 }else{
        		 System.out.println(n+" "+result);
        	 }
        	 
         }
	}
	public static int bfs(int n,Points st,Points ed,char[][][] map,boolean[][][] vis){
		
		Queue2 que = new Queue2();
		que.push(st);
		vis[st.z][st.y][st.x]=true;
		int to[][][] = {
				{{ 1,0,0 }}, 
				{{-1,0,0}},
				{{0,1,0}},
				{{0,-1,0}},
				{{0,0,1}},
				{{0,0,-1}}
		};
		
		while(!que.isEmpty()){
			Points tq = que.pop();
			if(tq.x==ed.x && tq.y==ed.y && tq.z==ed.z ){
				return tq.step;
			}
			for(int i=0;i<6;i++){
				for(int j=0;j<1;j++){
						int fx = tq.x+to[i][j][0];
						int fy = tq.y+to[i][j][1];
						int fz = tq.z+to[i][j][2];
					  if(fx>=0 && fx<n && fy>=0 && fy<n && fz>=0 && fz<n && !vis[fz][fy][fx] && map[fz][fy][fx]!='X'){
						  vis[fz][fy][fx] = true;
						  que.push(new Points(fx, fy, fz,tq.step+1));
					  }
					
				}
			}
			
		}			
		return -1;
	}
}
class Points{
	int x,y,z,step;
	public Points(){
	}	
	public Points(int x, int y, int z ,int step) {
		this.x = x;
		this.y = y;
		this.z = z;
		this.step = step;
	}	
}
class Queue2{
	List<Points> list = new ArrayList<Points>();
	public void push(Points p){
		list.add(p);
	}
	
	public Points pop(){
		if(list.size()>0){
			return list.remove(0);			
		}else{
			return null;
		}
	}
	public boolean isEmpty(){
		if(list.size()==0){
			return true;
		}else{
			return false;
		}
	}
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章