HDU 5914 - Triangle


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.


Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).


Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.


Sample Input
3
4
5
6


Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

 

題意:給出一個 n,分別有 1 - n 長度的木條各一條,問給出一個 n,求出去掉最少的木條數量,使剩下的木條中的任意 3 條均不能組成一個三角形。

讓剩下的木條長度都是斐波那契中的數項即可,因爲 n 只有20的大小,本渣渣純手推的。。。

#include <cstdio>

int main()
{
    int ans[30] = {0, 0, 0, 0, 1, 1, 2, 3, 3, 4, 5, 6, 7, 7, 8, 9, 10, 11, 12, 13, 14};
    int T;
    scanf("%d", &T);
    for (int icase = 1; icase <= T; ++icase)
    {
        int n;
        scanf("%d", &n);
        printf("Case #%d: %d\n", icase, ans[n]);
    }
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章