HDU 5734 - Acperience

Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn). Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi∈{+1,−1}) and a scaling factor α≥0 in such a manner that ∥W−αB∥2 is minimum.

Note that ∥⋅∥ denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−√, where X=(x1,x2,...,xn)).


Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integers n (1≤n≤100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (−10000≤wi≤10000).


Output
For each test case, output the minimum value of ∥W−αB∥2 as an irreducible fraction "p/q" where p, q are integers, q>0.


Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4


Sample Output
5/1
0/1
10/1

題意:給出一個公式,讓計算最小值。

最後推出那個式子等於x1^2+x2^2+……..+xn^2-n*(average^2)
其中的average爲這n個數絕對值的平均數,然後直接除求平均數的話會有精度損失。
然後對這個式子乘以n然後這個式子變爲了:n* (x1^2+x2^2+…….+xn^2) - sum*sum 其中sum爲這n個數的絕對值的和,然後再求這個式子與n的最大公約數。然後二者分別除以最大公約數就是這個題的結果了。

#include <cstdio>
#include <cstdlib>

long long GCD(long long a, long long b)
{
    if (b == 0)
        return a;
    return GCD(b, a%b);
}

int main()
{
    int T;
    scanf("%d", &T);

    while (T--)
    {
        long long n;
        long long sum = 0;
        long long up = 0;
        long long down = 0;
        scanf("%I64d", &n);
        for (long long i = 0; i < n; ++i)
        {
            long long tmp;
            scanf("%I64d", &tmp);
            up += tmp*tmp;
            sum += abs(tmp);
        }
        up = up*n - sum*sum;
        down = n;
        if (up == 0)
        {
            printf("0/1\n");
            continue;
        }
        long long div = GCD(up, down);
        printf("%I64d/%I64d\n", up/div, down/div);
    }
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章