hdu 1501 Zipper(DFS)

Zipper

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8638    Accepted Submission(s): 3058


Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

 

Output
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
Data set 1: yes Data set 2: yes Data set 3: no
 

Source
 

題意:

把B串的按串內字符順序不變的原則插入A串,問能不能得到C串。

題解:

把C串從前往後進行搜索,記得標記有過的狀態。

參考代碼:

<span style="font-size:14px;">#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define M 1005
bool vis[M][M];
bool fl;
char a[M],b[M],c[M];
void dfs(int la,int lb,int cnt)
{
	if(c[cnt]=='\0')
		fl=1;
	vis[la][lb]=1;
	if(a[la]==c[cnt])
		dfs(la+1,lb,cnt+1);
	if(b[lb]==c[cnt])
		dfs(la,lb+1,cnt+1);
	if(fl||vis[la][lb])
		return ;
}
int main()
{
	int t;
	scanf("%d",&t);
	int cas=1;
	while(t--)
	{
		fl=0;
		scanf("%s%s%s",a,b,c);
		memset(vis,0,sizeof(vis));
		dfs(0,0,0);
		printf("Data set %d: ",cas++);
		if(fl)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
} </span>

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章