hdu 5326 - Work(遞歸)解題報告

Work

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 992    Accepted Submission(s): 613


Problem Description


It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people. 
 

Input
There are multiple test cases.
Each test case begins with two integers n and k, n indicates the number of stuff of the company.
Each of the following n-1 lines has two integers A and B, means A is the direct leader of B.

1 <= n <= 100 , 0 <= k < n
1 <= A, B <= n
 

Output
For each test case, output the answer as described above.
 

Sample Input
7 2 1 2 1 3 2 4 2 5 3 6 3 7
 

Sample Output
2
 


題意:給你n-1個關係,a直接領導b。問這些人中有多少人可以領導K個人。領導包括直接領導和間接領導。

題解:比如1領導2,再去看2能領導幾個人,這裏就可以想到用遞歸做。用個計數器記錄1能領導(包括間接)的人數,記錄下所有人能領導的人數,遍歷一遍就能求出答案。

參考代碼:

#include<stdio.h>
#include<string.h>
struct node
{
	int num,s[105];
}res[105];
int ans;
void judge(int i)
{
	if(res[i].num==0)
	    return ;
	ans+=res[i].num;
	for(int j=0;j<res[i].num;j++)
	    judge(res[i].s[j]);
}
int main()
{
	int n,k,a,b,cnt;
	while(~scanf("%d%d",&n,&k))
	{
		memset(res,0,sizeof(res));
		for(int i=0;i<n-1;i++)
		{
			scanf("%d%d",&a,&b);
			res[a].s[res[a].num]=b;
			res[a].num++;
		}
		cnt=0;
		for(int i=1;i<=n;i++)
		{
			ans=res[i].num;
			for(int j=0;j<res[i].num;j++)
			    judge(res[i].s[j]);
            if(ans==k)
                cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章