HDU2141 Can you find it?

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
Case 1: NO YES NO

代碼:

#include <cstdio>
#include <algorithm>
using namespace std;
typedef long long ll;

const int maxn=505;
int a[maxn],b[maxn],c[maxn];
ll ab[maxn*maxn];

int main(){
    int l,n,m,kase=0;
    while(scanf("%d%d%d",&l,&n,&m)==3){
        for(int i=0;i<l;i++) scanf("%d",&a[i]);
        for(int i=0;i<n;i++) scanf("%d",&b[i]);
        for(int i=0;i<m;i++) scanf("%d",&c[i]);
        int num=0;
        for(int i=0;i<l;i++)
            for(int j=0;j<n;j++)
                ab[num++]=a[i]+b[j];
        sort(ab,ab+num);
        int s;
        scanf("%d",&s);
        printf("Case %d:\n",++kase);
        while(s--){
            int x,ok=0;
            scanf("%d",&x);
            for(int i=0;i<m;i++){
                if(binary_search(ab,ab+num,x-c[i])){
                    ok=1;
                    break;
                }
            }
            if(ok) puts("YES");
            else puts("NO");
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章